Asterisk
  1. Asterisk
  2. ASTERISK-10495

[PATCH] Flag to disable Packet2packet bridging

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/RTP
    • Labels:
      None
    • Source Revision Number:
      85355
    • Mantis ID:
      10943
    • Regression:
      No

      Description

      When packet2packet bridging 2 channels, monitoring doesn't work (generates empty files). The reason is that rtp packets don't get to core and are rapidly forwarded to the other peer.

      This patch adds a disablep2p flag to rtp.conf. It will force all bridges to be native.

      Julian.

      1. rtp_c_disablep2p_v1.diff
        1 kB
        Julian J. M.
      2. rtp_c_disablep2p_v2.diff
        1 kB
        Julian J. M.
      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Joshua Colp added a comment -

        Please provide more information, such as the monitor application being used and how. The code already has checks to make sure p2p/native is not even attempted if monitoring is used.

        Julian J. M. added a comment -

        This is for a custom recording application.

        Asterisk is between 2 SIP gateways, forwarding calls between the two.

        [from-gw1]
        exten => _X.,1,Dial(SIP/gw2/$

        {EXTEN}

        )
        exten => _X.,2,Hangup

        Without this patch, asterisk does a Packet2packet bridge.

        Then the application connects to the manager interface, and sends a "Monitor" action on one of the channels. The resulting file is empty.

        Before implementing this patch, I had to change the packetization on one of the gateways, to force a native bridge. I think this is a better solution.

        Julian J. M. added a comment -

        Just updated the patch (v2), because it was wrong: When we disable p2p bridges, we don't want to force a native one.

        Now, when packet2packet bridge was to be attempted, we silently fail, and force asterisk to do a generic bridge.

        Julian.

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 85552

        U branches/1.4/main/rtp.c

        ------------------------------------------------------------------------
        r85552 | file | 2007-10-15 09:34:23 -0500 (Mon, 15 Oct 2007) | 4 lines

        If Monitor or a spy was added to a P2P or native bridged channel bring the channel back to the generic bridging core so the monitor or spy operations work.
        (closes issue ASTERISK-10495)
        Reported by: julianjm

        ------------------------------------------------------------------------

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 85553

        _U trunk/
        U trunk/main/rtp.c

        ------------------------------------------------------------------------
        r85553 | file | 2007-10-15 09:37:01 -0500 (Mon, 15 Oct 2007) | 12 lines

        Merged revisions 85552 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r85552 | file | 2007-10-15 11:55:04 -0300 (Mon, 15 Oct 2007) | 4 lines

        If Monitor or a spy was added to a P2P or native bridged channel bring the channel back to the generic bridging core so the monitor or spy operations work.
        (closes issue ASTERISK-10495)
        Reported by: julianjm

        ........

        ------------------------------------------------------------------------


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development