Asterisk
  1. Asterisk
  2. ASTERISK-11082

Voicemail cuts off at 60 seconds regardless of config settings

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Source Revision Number:
      93925
    • Mantis ID:
      11600
    • Regression:
      No

      Description

      Voicemail cuts off at 60 seconds regardless of voicemail.conf setting.
      Attached is the file exactly 1:00 min long cutting off. Source of the call doesn't matter.

                • ADDITIONAL INFORMATION ******

      Asterisk verbose 9999:
      ----------------------------------------------------------
      – Executing [s@incoming-voicemail:12] VoiceMail("SIP/sTp57GEb98-08218510", "0001|s") in new stack
      – <SIP/sTp57GEb98-08218510> Playing 'beep' (language 'en')
      – Recording the message
      – x=0, open writing: /var/spool/asterisk/voicemail/default/0001/tmp/5ZGWsZ format: wav49, 0x8217e10
      == Refreshing DNS lookups.
      – User hung up
      == Spawn extension (incoming-voicemail, s, 12) exited non-zero on 'SIP/sTp57GEb98-08218510'
      ----------------------------------------------------------

      Voicemail.conf

      maxmessage=600

      1. full_voice.txt
        432 kB
      2. full_voicemail.txt
        561 kB
      3. msg0005.WAV
        96 kB
      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Arcadiy Ivanov added a comment -

        Changing maxmessage=600 to maxmessage=300 still results in 60 sec cutoff. Not a second to millisecond conversion issue.

        Jason Parker added a comment -

        I assume this is being tested from a SIP phone? Can you get a SIP debug near the end, when the "User hung up" message would occur?

        Have you tried recording from IAX2 or zap channels?

        Joshua Colp added a comment -

        Complete console log with debug enabled in logger.conf would also be useful.

        Arcadiy Ivanov added a comment -

        Attached are requested log files containing the results of three tests.

        Test 1 (full_voicemail.txt): Call Voicepulse Connect number A from mobile B, do not pick up, get connected to voicemail.

        Test 1 result: Reached voicemail, cutoff at exactly 60 seconds.

        Test 2 (full_voice.txt): Call Voicepulse Connect number A from mobile B, pick up, talk.

        Test 2 result: Talked for 120 seconds with no problems. Hangup.

        Test 3 (logs not included): Call Telphin number C from SkypeOut, do not pick up, get connected to voicemail.

        Test 3 result: Reached voicemail, left voicemail over 3 minutes long. Hangup.

        Conclusion: Looks like Voicepulse Connect-specific problem while recording voicemail: no keep-alives/pings/pongs are sent back? Voicepulse thinks * dropped the connection?

        Logs: Files have been cleaned up: nonces, usernames, phone numbers removed.

        Joshua Colp added a comment -

        Voicepulse Connect seems to have the rtptimeout option set to 60 seconds, and by default nothing is sent back when Asterisk is doing a recording. This can be changed so it sends back silence by setting transmit_silence_during_record to yes in the options context of asterisk.conf


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: