Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Addons/New Feature
    • Labels:
      None
    • SVN Revision Number:
      497
    • Mantis ID:
      11614
    • Regression:
      No

      Description

      Adding T38 support to SendFax/ReceiveFax applications. See Additional Information for details.

      There are two patches:

      • appfax-v3.patch for asterisk-addons/trunk rev 497 - modifications to the fax application
      • asterisk-t38.patch - temporary (see below) patch for asterik/trunk revision 94396

      Unable to render embedded object: File (IMPORTANT NOTE) not found. This patch is considered work in progress because it depends on not yet finished feature of Asterisk - ability to request T38 reinvite on a SIP channel.
      Currently, the patch adds this ability itself (asterisk-t38.patch) but it adds it in a very rude way. It is clearly a hack. When file finishes his t38insanity branch and Aterisk will get official way of requesting re-invite, I will update app_fax to use that way instead and asterisk-t38.patch won't be needed anymore.

                • ADDITIONAL INFORMATION ******

      Changes:

      1. T38 support added. When acting as receiver, as soon as we detect CNG tone, we request T38. IWhen T38 is negotiated (if it is negotiated), we switch to T38 mode. When acting as sender we do not offer re-invite (because spec says it is receiver side business) but if T38 is offered by remote side, we switch to it.

      2. The regular (audio) fax re-implemented using Asterisk generators. This should have no consequences for ordinary users but it now allows "connecting" SendFAX to ReceiveFAX both running on the same PBX for tests.

      3. 'd' option (debug) is removed. Now you control amount of debugging with the global 'core set debug' CLI command. Depending on the level, different things are logged:
      0 - obviously nothing
      1 - only the minimum from app_fax + SpanDSP protocol errors and above (warnings and errors)
      2-8 - map to SpanDSP levels from SPAN_LOG_PROTOCOL_WARNING to SPAN_LOG_DEBUG_3 (see SpanDSP logging.h)
      20 - display frametype/subtype of all frames received by app_fax

      usually you need something like 'core set debug 3'

      1. appfax-v3.patch
        23 kB
        Dmitry Andrianov
      2. asterisk-t38.patch
        2 kB
        Dmitry Andrianov
      3. v4-appfax.patch
        24 kB
        Dmitry Andrianov
      4. v4-asterisk-t38.patch
        13 kB
        Dmitry Andrianov
      5. v5-appfax.patch
        25 kB
        Dmitry Andrianov
      6. v6-appfax.patch
        25 kB
        Dmitry Andrianov
      7. v7-appfax.patch
        25 kB
        Dmitry Andrianov
      8. v8-appfax.patch
        25 kB
        Dmitry Andrianov

        Activity

        Dmitry Andrianov added a comment -

        removed debugging accidently left in the code

        Douglas Gillespie added a comment -

        Good work! What version does this apply too? Trunk? 1.6? Thanks..

        Dmitry Andrianov added a comment -

        trunk

        Dmitry Andrianov added a comment -

        Patch updated to match file's changes in T38 API as well as reorganization in the addons tree.

        Digium Subversion added a comment -

        Repository: asterisk-addons
        Revision: 533

        U trunk/apps/app_fax.c

        ------------------------------------------------------------------------
        r533 | file | 2008-02-20 16:45:57 -0600 (Wed, 20 Feb 2008) | 6 lines

        Add support for T38 to app_fax since Asterisk now has an API and way of doing things with it.
        (closes issue ASTERISK-11094)
        Reported by: dimas
        Patches:
        v8-appfax.patch uploaded by dimas (license 88)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk-addons?view=rev&revision=533


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development