Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Mantis ID:
      11700
    • Regression:
      No

      Description

      777 => queue extension
      201 => caller
      758 => queue agent
      779 => "pickuper"

      Extension 201 calls queue 777, queue agent 758 is in ringing state but 779 cannot pickup the call:

      app_directed_pickup.c:161 pickup_exec: No target channel found for 758
      app_directed_pickup.c:161 pickup_exec: No target channel found for 777

                • ADDITIONAL INFORMATION ******

      queue application is called from context ext-queues, so in my understanding call should be pickuped with Pickup($

      {EXTEN:2}

      @ext-queues) or Pickup(777@ext-queues) but in both cases target channel cannot be found.

      show channels shows this while SIP/758 is ringing:

      asterisk*CLI> show channels
      Channel Location State Application(Data)
      SIP/758-084aa238 (None) Ringing AppQueue((Outgoing Line))
      SIP/201-082d83e0 777 <at> from-internal:11 Up Queue(777|t|||300)
      2 active channels
      1 active call

      1. 11700.diff
        0.9 kB
        Joshua Colp
      2. console_output_with patch.txt
        3 kB
      3. console_output.txt
        3 kB
      4. pickup_context.txt
        0.6 kB

        Activity

        Joshua Colp added a comment -

        Please try the attached patch.

        jbauer added a comment -

        The patch works! Thank your very much! I get some warnings that one channel is already going to masquerade the other channel (see attached console output). I am going to test this more and give you more feedback.

        Joshua Colp added a comment -

        It is because you keep falling through trying. You have one Pickup that works, and then you go to the next Pickup which also works. The only thing is that since no frames have yet passed the masquerade operation (which Pickup uses) did not happen yet from the first Pickup and the second one gets confused.

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 97093

        U branches/1.4/apps/app_queue.c

        ------------------------------------------------------------------------
        r97093 | file | 2008-01-08 12:33:12 -0600 (Tue, 08 Jan 2008) | 4 lines

        Make app_queue calls work with directed pickup.
        (closes issue ASTERISK-11171)
        Reported by: jbauer

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=97093

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 97103

        _U trunk/
        U trunk/apps/app_queue.c

        ------------------------------------------------------------------------
        r97103 | file | 2008-01-08 12:39:06 -0600 (Tue, 08 Jan 2008) | 12 lines

        Merged revisions 97093 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r97093 | file | 2008-01-08 14:36:40 -0400 (Tue, 08 Jan 2008) | 4 lines

        Make app_queue calls work with directed pickup.
        (closes issue ASTERISK-11171)
        Reported by: jbauer

        ........

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=97103


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development