Asterisk
  1. Asterisk
  2. ASTERISK-11460

Loading chan_mobile.so results in undefined symbol hci_get_route and immediate asterisk stop

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Addons/chan_mobile
    • Labels:
      None
    • SVN Revision Number:
      103754
    • Mantis ID:
      12015
    • Regression:
      No

      Description

      Asterisk runs normally unless chan_mobile module is loaded. On load, the following error message is shown:

      asterisk: symbol lookup error: /usr/lib/asterisk/modules/chan_mobile.so: undefined symbol: hci_get_route

      Asterisk immediately stops and returns me to a command line.

      Build of asterisk and chan_mobile was clean, no errors reported.

      I have bluez libs (3.26-2.1) and utils (3.24-2.1) installed and apparently functional. (Able to scan, connect, etc. to phones.)

      This is on asterisk-addons trunk, r531.

                • STEPS TO REPRODUCE ******

      Added chan_mobile.so to noload in modules.conf.
      Started asterisk, confirmed normal functionality with test call.
      loaded chan_mobile module

        Activity

        Jason Parker added a comment -

        What is the output of an ldd on chan_mobile.so?

        bwern added a comment -

        I've attached the LDD output as a file - quite a few undefined references; apparently I am missing a prerequisite? I though I had that covered between the libs and utils packages.

        Joshua Colp added a comment -

        That is ld output, not ldd.

        bwern added a comment -

        My mistake! ldd says:

        1. ldd /usr/lib/asterisk/modules/chan_mobile.so
          linux-gate.so.1 => (0xffffe000)
          libc.so.6 => /lib/libc.so.6 (0xb7e56000)
          /lib/ld-linux.so.2 (0x80000000
        gkloepfer added a comment -

        I had the same problem - the Makefile doesn't seem to link the module with the Bluetooth library.

        This probably isn't the absolute correct way to do this, but will get you through the compile:

        add the following to the end of asterisk-addons-trunk/channels/Makefile:

        chan_mobile.so: LIBS+=-lbluetooth

        Hope that helps.

        Joshua Colp added a comment -

        The way it is supposed to work is that menuselect sees the dependency on bluetooth and automatically links chan_mobile against it, which it does on my system for example. I'm curious - what this a fresh checkout? If not can you perform a fresh checkout and try? What is the output of configure?

        gkloepfer added a comment -

        I see the problem - it looks like one of the unofficial patches that allows chan_mobile to work on 1.4 removes the link dependency on bluetooth (as you indicated).

        The part of the patch that removes the:

        <depend>bluetooth</depend>

        from the MODULEINFO part of chan_mobile.c should NOT have been done.

        That fixed it...should have seen it earlier.

        Jason Parker added a comment -

        In light of gkloepfer's comment about "unofficial patches", I am going to close this issue. If you are not using any patches, please feel free to reopen this issue, so we can look at it further.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development