Asterisk
  1. Asterisk
  2. ASTERISK-11913

[patch] comments on sample files refers to unexistent README file

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Documentation
    • Labels:
      None
    • Source Revision Number:
      114611
    • Mantis ID:
      12516
    • Regression:
      No

      Description

      zapata.conf.sample -> README.callingpres should be callingpres.txt
      sip.conf.sample -> README.tos should be ip-tos.txt
      iaxprov.conf.sample -> README.tos should be ip-tos.txt

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 114649

        U branches/1.4/configs/iax.conf.sample
        U branches/1.4/configs/iaxprov.conf.sample
        U branches/1.4/configs/sip.conf.sample
        U branches/1.4/configs/zapata.conf.sample

        ------------------------------------------------------------------------
        r114649 | tilghman | 2008-04-25 10:48:40 -0500 (Fri, 25 Apr 2008) | 6 lines

        Reference documentation files that actually exist.
        (closes issue ASTERISK-11913)
        Reported by: linuxmaniac
        Patches:
        diff_rev114611.patch uploaded by linuxmaniac (license 472)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=114649

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 114650

        _U trunk/

        ------------------------------------------------------------------------
        r114650 | tilghman | 2008-04-25 10:53:22 -0500 (Fri, 25 Apr 2008) | 13 lines

        Blocked revisions 114649 via svnmerge

        ........
        r114649 | tilghman | 2008-04-25 10:53:52 -0500 (Fri, 25 Apr 2008) | 6 lines

        Reference documentation files that actually exist.
        (closes issue ASTERISK-11913)
        Reported by: linuxmaniac
        Patches:
        diff_rev114611.patch uploaded by linuxmaniac (license 472)

        ........

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=114650

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 114669

        _U team/seanbright/resolve-shadow-warnings/
        U team/seanbright/resolve-shadow-warnings/apps/app_chanspy.c
        U team/seanbright/resolve-shadow-warnings/apps/app_dial.c
        U team/seanbright/resolve-shadow-warnings/apps/app_directed_pickup.c
        U team/seanbright/resolve-shadow-warnings/apps/app_externalivr.c
        U team/seanbright/resolve-shadow-warnings/apps/app_followme.c
        U team/seanbright/resolve-shadow-warnings/apps/app_minivm.c
        U team/seanbright/resolve-shadow-warnings/apps/app_parkandannounce.c
        D team/seanbright/resolve-shadow-warnings/apps/app_pickupchan.c
        U team/seanbright/resolve-shadow-warnings/apps/app_playback.c
        U team/seanbright/resolve-shadow-warnings/apps/app_queue.c
        U team/seanbright/resolve-shadow-warnings/apps/app_rpt.c
        U team/seanbright/resolve-shadow-warnings/apps/app_sms.c
        U team/seanbright/resolve-shadow-warnings/apps/app_speech_utils.c
        U team/seanbright/resolve-shadow-warnings/apps/app_voicemail.c
        U team/seanbright/resolve-shadow-warnings/apps/app_waitforring.c
        U team/seanbright/resolve-shadow-warnings/apps/app_zapscan.c
        U team/seanbright/resolve-shadow-warnings/main/app.c
        U team/seanbright/resolve-shadow-warnings/main/features.c

        ------------------------------------------------------------------------
        r114669 | seanbright | 2008-04-25 15:38:05 -0500 (Fri, 25 Apr 2008) | 97 lines

        Merged revisions 114650-114651,114655-114656,114660,114663,114665,114667 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/trunk

        ................
        r114650 | tilghman | 2008-04-25 11:58:36 -0400 (Fri, 25 Apr 2008) | 13 lines

        Blocked revisions 114649 via svnmerge

        ........
        r114649 | tilghman | 2008-04-25 10:53:52 -0500 (Fri, 25 Apr 2008) | 6 lines

        Reference documentation files that actually exist.
        (closes issue ASTERISK-11913)
        Reported by: linuxmaniac
        Patches:
        diff_rev114611.patch uploaded by linuxmaniac (license 472)

        ........

        ................
        r114651 | mmichelson | 2008-04-25 12:25:17 -0400 (Fri, 25 Apr 2008) | 4 lines

        Fix a memory leak and protect against potential dereferences of a NULL
        pointer.

        ................
        r114655 | russell | 2008-04-25 14:18:27 -0400 (Fri, 25 Apr 2008) | 10 lines

        Merge code from team/russell/parking_updates

        Add some additional features to the core park_call_full() function, and expose
        them as options to the Park() application. The functionality being added is the
        ability to specify a custom return extension/context/priority, a custom timeout,
        and a couple of options. The options are to play ringing instead of MOH to the
        parked caller, and to randomize parking spot selection.

        (code inspired by the patch in AST-17, code from switchvox)

        ................
        r114656 | mmichelson | 2008-04-25 14:18:30 -0400 (Fri, 25 Apr 2008) | 13 lines

        This patch allows for forwarding a message with a "comment" attachment
        if using IMAP storage for voicemail. The comment will be recorded and attached
        as a second attachment in addition to the original message. This will be invoked
        if you choose to prepend a message the way you would with file or ODBC storage

        (closes issue ASTERISK-11473)
        Reported by: jaroth
        Patches:
        forward_with_comment_v2.patch uploaded by jaroth (license 50)
        Tested by: jaroth

        ................
        r114660 | qwell | 2008-04-25 14:32:22 -0400 (Fri, 25 Apr 2008) | 12 lines

        Merge app_pickupchan with app_directed_pickup, for AST-27.

        Initially, this was to be a new feature, with a patch from Switchvox,
        but after discussions, it was noted that this feature already existed in trunk.

        The resulting discussions ended in a comment that was along the lines of
        "the patch provided here is a lot smaller than what is already in trunk,
        because it doesn't create a new application and duplicate existing code"

        It was decided that these two applications could be easily merged to reduce
        code duplication. SO, that's what this does.

        ................
        r114663 | mmichelson | 2008-04-25 15:33:27 -0400 (Fri, 25 Apr 2008) | 12 lines

        Merged revisions 114662 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r114662 | mmichelson | 2008-04-25 14:32:02 -0500 (Fri, 25 Apr 2008) | 4 lines

        Move the unlock of the spyee channel to outside the start_spying() function so that
        the channel is not unlocked twice when using whisper mode.

        ........

        ................
        r114665 | tilghman | 2008-04-25 15:39:26 -0400 (Fri, 25 Apr 2008) | 2 lines

        Oops, this isn't necessarily AGI that is forking anymore

        ................
        r114667 | tilghman | 2008-04-25 16:20:10 -0400 (Fri, 25 Apr 2008) | 2 lines

        Whitespace changes only

        ................

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=114669

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 114672

        _U branches/1.6.0/

        ------------------------------------------------------------------------
        r114672 | russell | 2008-04-25 16:41:14 -0500 (Fri, 25 Apr 2008) | 20 lines

        Blocked revisions 114650 via svnmerge

        ................
        r114650 | tilghman | 2008-04-25 10:58:36 -0500 (Fri, 25 Apr 2008) | 13 lines

        Blocked revisions 114649 via svnmerge

        ........
        r114649 | tilghman | 2008-04-25 10:53:52 -0500 (Fri, 25 Apr 2008) | 6 lines

        Reference documentation files that actually exist.
        (closes issue ASTERISK-11913)
        Reported by: linuxmaniac
        Patches:
        diff_rev114611.patch uploaded by linuxmaniac (license 472)

        ........

        ................

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=114672

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 114686

        _U team/seanbright/res-jabber-astobj2/
        U team/seanbright/res-jabber-astobj2/CHANGES
        U team/seanbright/res-jabber-astobj2/apps/app_chanspy.c
        U team/seanbright/res-jabber-astobj2/apps/app_dial.c
        U team/seanbright/res-jabber-astobj2/apps/app_directed_pickup.c
        U team/seanbright/res-jabber-astobj2/apps/app_externalivr.c
        U team/seanbright/res-jabber-astobj2/apps/app_followme.c
        U team/seanbright/res-jabber-astobj2/apps/app_minivm.c
        U team/seanbright/res-jabber-astobj2/apps/app_parkandannounce.c
        D team/seanbright/res-jabber-astobj2/apps/app_pickupchan.c
        U team/seanbright/res-jabber-astobj2/apps/app_playback.c
        U team/seanbright/res-jabber-astobj2/apps/app_queue.c
        U team/seanbright/res-jabber-astobj2/apps/app_rpt.c
        U team/seanbright/res-jabber-astobj2/apps/app_sms.c
        U team/seanbright/res-jabber-astobj2/apps/app_speech_utils.c
        U team/seanbright/res-jabber-astobj2/apps/app_voicemail.c
        U team/seanbright/res-jabber-astobj2/apps/app_waitforring.c
        U team/seanbright/res-jabber-astobj2/apps/app_zapscan.c
        U team/seanbright/res-jabber-astobj2/channels/chan_iax2.c
        U team/seanbright/res-jabber-astobj2/channels/chan_sip.c
        U team/seanbright/res-jabber-astobj2/main/app.c
        U team/seanbright/res-jabber-astobj2/main/features.c
        U team/seanbright/res-jabber-astobj2/pbx/pbx_lua.c

        ------------------------------------------------------------------------
        r114686 | seanbright | 2008-04-25 22:49:48 -0500 (Fri, 25 Apr 2008) | 146 lines

        Merged revisions 114650-114651,114655-114656,114660,114663,114665,114667,114674,114676,114678,114683 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/trunk

        ................
        r114650 | tilghman | 2008-04-25 11:58:36 -0400 (Fri, 25 Apr 2008) | 13 lines

        Blocked revisions 114649 via svnmerge

        ........
        r114649 | tilghman | 2008-04-25 10:53:52 -0500 (Fri, 25 Apr 2008) | 6 lines

        Reference documentation files that actually exist.
        (closes issue ASTERISK-11913)
        Reported by: linuxmaniac
        Patches:
        diff_rev114611.patch uploaded by linuxmaniac (license 472)

        ........

        ................
        r114651 | mmichelson | 2008-04-25 12:25:17 -0400 (Fri, 25 Apr 2008) | 4 lines

        Fix a memory leak and protect against potential dereferences of a NULL
        pointer.

        ................
        r114655 | russell | 2008-04-25 14:18:27 -0400 (Fri, 25 Apr 2008) | 10 lines

        Merge code from team/russell/parking_updates

        Add some additional features to the core park_call_full() function, and expose
        them as options to the Park() application. The functionality being added is the
        ability to specify a custom return extension/context/priority, a custom timeout,
        and a couple of options. The options are to play ringing instead of MOH to the
        parked caller, and to randomize parking spot selection.

        (code inspired by the patch in AST-17, code from switchvox)

        ................
        r114656 | mmichelson | 2008-04-25 14:18:30 -0400 (Fri, 25 Apr 2008) | 13 lines

        This patch allows for forwarding a message with a "comment" attachment
        if using IMAP storage for voicemail. The comment will be recorded and attached
        as a second attachment in addition to the original message. This will be invoked
        if you choose to prepend a message the way you would with file or ODBC storage

        (closes issue ASTERISK-11473)
        Reported by: jaroth
        Patches:
        forward_with_comment_v2.patch uploaded by jaroth (license 50)
        Tested by: jaroth

        ................
        r114660 | qwell | 2008-04-25 14:32:22 -0400 (Fri, 25 Apr 2008) | 12 lines

        Merge app_pickupchan with app_directed_pickup, for AST-27.

        Initially, this was to be a new feature, with a patch from Switchvox,
        but after discussions, it was noted that this feature already existed in trunk.

        The resulting discussions ended in a comment that was along the lines of
        "the patch provided here is a lot smaller than what is already in trunk,
        because it doesn't create a new application and duplicate existing code"

        It was decided that these two applications could be easily merged to reduce
        code duplication. SO, that's what this does.

        ................
        r114663 | mmichelson | 2008-04-25 15:33:27 -0400 (Fri, 25 Apr 2008) | 12 lines

        Merged revisions 114662 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r114662 | mmichelson | 2008-04-25 14:32:02 -0500 (Fri, 25 Apr 2008) | 4 lines

        Move the unlock of the spyee channel to outside the start_spying() function so that
        the channel is not unlocked twice when using whisper mode.

        ........

        ................
        r114665 | tilghman | 2008-04-25 15:39:26 -0400 (Fri, 25 Apr 2008) | 2 lines

        Oops, this isn't necessarily AGI that is forking anymore

        ................
        r114667 | tilghman | 2008-04-25 16:20:10 -0400 (Fri, 25 Apr 2008) | 2 lines

        Whitespace changes only

        ................
        r114674 | russell | 2008-04-25 18:00:35 -0400 (Fri, 25 Apr 2008) | 11 lines

        Merged revisions 114673 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r114673 | russell | 2008-04-25 16:54:40 -0500 (Fri, 25 Apr 2008) | 3 lines

        Use consistent logic for checking to see if a call number has been chosen yet.
        Also, remove some redundant logic I recently added in a fix.

        ........

        ................
        r114676 | russell | 2008-04-25 18:04:46 -0400 (Fri, 25 Apr 2008) | 7 lines

        Lock the channel around datastore access

        (closes issue ASTERISK-11922)
        Reported by: mnicholson
        Patches:
        pbx_lua4.diff uploaded by mnicholson (license 96)

        ................
        r114678 | mmichelson | 2008-04-25 18:24:32 -0400 (Fri, 25 Apr 2008) | 11 lines

        Adding a new option, 'B' to app_chanspy. This option allows the spy to
        barge on the call. It is like the existing whisper option, except that
        it allows the spy to talk to both sides of the conversation on which
        he is spying.

        This feature has existed in Switchvox, and this merges the functionality
        into Asterisk.

        (AST-32)

        ................
        r114683 | tilghman | 2008-04-25 22:48:56 -0400 (Fri, 25 Apr 2008) | 8 lines

        Add 'sip qualify peer <peer>' command (with AMI SIPqualifypeer)
        (closes issue ASTERISK-11920)
        Reported by: ctooley
        Patches:
        sip_qualify_peer.diff.2 uploaded by ctooley (license 136)
        some modifications for trunk by Corydon76
        Tested by: Corydon76

        ................

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=114686


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development