Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/RTP
    • Labels:
      None
    • Mantis ID:
      12628
    • Regression:
      No

      Description

      I have this in my dialplan:

      exten => 123,1,Read(NUMBER,,9)
      exten => 123,n,NoOp($

      {NUMBER}

      )

      And most of the time when I press "123" and then I press "123456789" I don't get the full digits.

      I get something like:

      – Executing [123@default:2] NoOp("SIP/diego.viola-10aadc00", "12389") in new stack

      – Executing [123@default:2] NoOp("SIP/diego.viola-10a9cf30", "1234579") in new stack

      – Executing [123@default:2] NoOp("SIP/diego.viola-10a9b1c0", "1234789") in new stack

      – Executing [123@default:2] NoOp("SIP/diego.viola-10a8fae0", "123679") in new stack

      I don't know if this is due to network problems, or not... but FreeSWITCH developers told me they can handle this just fine, and this is a serious issue because most of my users sometimes get back to me and say "hey my password doesn't work" and I think is because of this.

      My Asterisk version is 1.4.19.1 and I compiled it with GCC 4.1.2, running on Linux 2.6.18 (x86_64) – CentOS release 5 (Final)

        Activity

        Diego Viola added a comment -

        This is what I get with Zoiper:

        [Jun 8 22:13:02] NOTICE[13601]: chan_sip.c:15092 handle_request_subscribe: Received SIP subscribe for peer without mailbox: diego.viola
        – Executing [123@default:1] Read("SIP/diego.viola-06412090", "NUMBER||9") in new stack
        – Accepting a maximum of 9 digits.
        – User entered '111122223'
        – Executing [123@default:2] NoOp("SIP/diego.viola-06412090", "111122223") in new stack
        == Auto fallthrough, channel 'SIP/diego.viola-06412090' status is 'UNKNOWN'
        [Jun 8 22:13:21] NOTICE[13601]: chan_sip.c:14033 handle_request_invite: Call from 'diego.viola' to extension '123456789' rejected because extension not found.
        – Executing [123@default:1] Read("SIP/diego.viola-063e6fa0", "NUMBER||9") in new stack
        – Accepting a maximum of 9 digits.
        – User entered '111122223'
        – Executing [123@default:2] NoOp("SIP/diego.viola-063e6fa0", "111122223") in new stack
        == Auto fallthrough, channel 'SIP/diego.viola-063e6fa0' status is 'UNKNOWN'
        – Executing [123@default:1] Read("SIP/diego.viola-063e6fa0", "NUMBER||9") in new stack
        – Accepting a maximum of 9 digits.
        – User entered '111122223'
        – Executing [123@default:2] NoOp("SIP/diego.viola-063e6fa0", "111122223") in new stack
        == Auto fallthrough, channel 'SIP/diego.viola-063e6fa0' status is 'UNKNOWN'
        – Executing [123@default:1] Read("SIP/diego.viola-06410380", "NUMBER||9") in new stack
        – Accepting a maximum of 9 digits.
        – User entered '111122223'
        – Executing [123@default:2] NoOp("SIP/diego.viola-06410380", "111122223") in new stack
        == Auto fallthrough, channel 'SIP/diego.viola-06410380' status is 'UNKNOWN'
        – Executing [123@default:1] Read("SIP/diego.viola-06412090", "NUMBER||9") in new stack
        – Accepting a maximum of 9 digits.
        – User entered '111122223'
        – Executing [123@default:2] NoOp("SIP/diego.viola-06412090", "111122223") in new stack
        == Auto fallthrough, channel 'SIP/diego.viola-06412090' status is 'UNKNOWN'

        Joshua Colp added a comment -

        Please provide an rtp debug with Zoiper connected and hitting DTMF digits.

        Diego Viola added a comment -

        I just added the file: rtp_debug_zoiper_dtmf.txt, please let me know if you need anything else.

        Diego Viola added a comment -

        Upgraded to 1.4.21 and the problem is still there.

        John Todd added a comment -

        In TRUNK as of this date, I could not reproduce. I also was using zoiper for Mac (2.07 library revision 1809)

        exten => 888,1,Answer()
        exten => 888,n,Read(FOO,,5)
        exten => 888,n,NoOp($

        {FOO}

        )
        exten => 888,n,Hangup

        Entered: 12354 on zoiper keypad. Distilled RFC messages from general RTP output.

        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053253, ts 1329664875, len 000004, mark 0, event 00000001, end 0, duration 00000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053257, ts 1329665515, len 000004, mark 0, event 00000001, end 0, duration 00500)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053260, ts 1329665995, len 000004, mark 0, event 00000001, end 0, duration 01000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053263, ts 1329666475, len 000004, mark 0, event 00000001, end 1, duration 01500)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053278, ts 1329668875, len 000004, mark 0, event 00000002, end 0, duration 00000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053281, ts 1329669355, len 000004, mark 0, event 00000002, end 0, duration 00500)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053284, ts 1329669835, len 000004, mark 0, event 00000002, end 0, duration 01000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053287, ts 1329670315, len 000004, mark 0, event 00000002, end 1, duration 01500)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053309, ts 1329673835, len 000004, mark 0, event 00000003, end 0, duration 00000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053312, ts 1329674315, len 000004, mark 0, event 00000003, end 0, duration 00500)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053315, ts 1329674795, len 000004, mark 0, event 00000003, end 0, duration 01000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053318, ts 1329675275, len 000004, mark 0, event 00000003, end 1, duration 01500)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053350, ts 1329680395, len 000004, mark 0, event 00000005, end 0, duration 00000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053353, ts 1329680875, len 000004, mark 0, event 00000005, end 0, duration 00500)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053356, ts 1329681355, len 000004, mark 0, event 00000005, end 0, duration 01000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053359, ts 1329681835, len 000004, mark 0, event 00000005, end 1, duration 01500)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053390, ts 1329686795, len 000004, mark 0, event 00000004, end 0, duration 00000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053393, ts 1329687275, len 000004, mark 0, event 00000004, end 0, duration 00500)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053396, ts 1329687755, len 000004, mark 0, event 00000004, end 0, duration 01000)
        Got RTP RFC2833 from 10.10.3.4:8000 (type 101, seq 053400, ts 1329688395, len 000004, mark 0, event 00000004, end 1, duration 01500)
        – User entered '12354'
        – Executing [888@test:3] NoOp("SIP/2204-82e312354") in new stack
        – Executing [888@test:4] Hangup("SIP/2204-82e3b014", "") in new stack
        == Spawn extension (test, 888, 4) exited non-zero on 'SIP/2204-82e3b014'


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development