Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Mantis ID:
      13209
    • Regression:
      No

      Description

      Using provider bandwidth.com which support RFC2833. Configure outbound trunk to use dtmfmode=rfc2833 and we receive double digits on a different asterisk servers IVR. American Express IVR does not accept any digits (used main customer service line to test entering credit card number). Other IVR functions do not work.

      Changing to inband works but inband should not be required by bandwidth.com, they support rfc2833.

      Configuration is using SIP devices and SIP trunks only. A search in issue tracker found similar problems in January of 2008 but no currently open issues.

      1. 13209.diff
        1.0 kB
        Joshua Colp
      2. capture.txt
        5 kB
      3. rfc2833_dtmf.pcap
        735 kB
      4. vp_rtp_debug.txt
        880 kB
      5. wrong DTMF duration.txt
        0.9 kB

        Issue Links

          Activity

          Mark Hamilton added a comment -

          Guys, I think we've provided enough information to the Asterisk developers to get this rectified. Although I think it's taken too long and it's still not responded to (leave alone fixed), maybe we should now give it a rest and wait for some response.

          At this point, I doubt they need more info than more time to fix it. May the force be with with developers.

          Joshua Colp added a comment -

          Please give the attached patch a go. It fixes some issues with timestamps. If it does not work please attach the following: complete console output, wireshark capture, rtp debug, sip.conf configuration file, plus an explanation of what you hit versus what actually happened.

          Buddy Jones added a comment -

          It looks like the patch resolved the issue. I have tested it on several IVRs that were giving me the most grief.

          Thanks.

          rbosch added a comment -

          In my tests the patch resolves the issue!

          Rob

          Digium Subversion added a comment -

          Repository: asterisk
          Revision: 162204

          U branches/1.4/main/rtp.c

          ------------------------------------------------------------------------
          r162204 | file | 2008-12-09 13:47:03 -0600 (Tue, 09 Dec 2008) | 7 lines

          Make sure that the timestamp for DTMF is not the same as the previous voice frame and do not send audio when transmitting DTMF as this confuses some equipment.
          (closes issue ASTERISK-12493)
          Reported by: ip-rob
          Patches:
          13209.diff uploaded by file (license 11)
          Tested by: ip-rob, bujones

          ------------------------------------------------------------------------

          http://svn.digium.com/view/asterisk?view=rev&revision=162204


            People

            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development