Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Mantis ID:
      13238
    • Regression:
      No

      Description

      core show hint shows false value of dev state:

      asterisk-IBM*CLI> core show hint 1231
      1231@hints : SIP/1231 State:InUse Watchers 0
      1 hint matching extension 1231

      asterisk-IBM:/usr/src# rasterisk -x "core show channels" | grep 1231
      asterisk-IBM:/usr/src#

      asterisk-IBM:/usr/src# rasterisk -x "sip show channels" | grep 1231

      SIP/1231 is asterisk 1.4.19, asterisk IBM (where I do core show hints) is 1.6.beta9

      Restarting asterisk on 1231 does not solve the problem.

      1. 20090121__bug13238.diff.txt
        0.6 kB
        Tilghman Lesher
      2. channel.c_1.6.0_rc6_diff.txt
        1.0 kB
        Alec Davis

        Activity

        Alec Davis added a comment -

        sip show inuse is correct
        ...
        GXP0001 1/0/0 10

        So, hints notification is another issue?

        core show hints show idle and should show InUse
        8512@BLF_Group_1 : SIP/GXP0001 State:Idle Watchers 5

        Alec Davis added a comment -

        I hadn't applied 20090121__bug13238.diff.txt, which fixes the hints issue.
        This was required as well as the changes made to trunk chan_sip.c today.

        I made about 50 calls, and every time the BLF on the grandstream was correct.

        The console output was correct, GXP0001 never went to Idle.

        Some console output below, with some debug.

        [Feb 11 12:15:53] NOTICE[14606]: chan_sip.c:5294 update_call_counter: INC_CALL_RINGING name=GXP0001 inringing=1
        [Feb 11 12:15:53] NOTICE[14606]: chan_sip.c:5305 update_call_counter: INC_CALL_RINGING name=GXP0001 inuse=2
        – Called GXP0001
        == Extension Changed 8512[BLF_Group_1] new state InUse&Ringing for Notify User GXP0003
        == Extension Changed 8512[BLF_Group_1] new state InUse&Ringing for Notify User GXP0002
        == Extension Changed 8512[BLF_Group_1] new state InUse&Ringing for Notify User GXP0004
        == Extension Changed 8512[BLF_Group_1] new state InUse&Ringing for Notify User GXP0001
        == Extension Changed 8512[BLF_Group_1] new state InUse&Ringing for Notify User GXP0005
        – SIP/GXP0001-088e90a0 is ringing
        [Feb 11 12:15:55] NOTICE[14512]: chan_sip.c:5236 update_call_counter: DEC_CALL_LIMIT name=8512 inuse=0
        [Feb 11 12:15:55] NOTICE[14606]: chan_sip.c:5236 update_call_counter: DEC_CALL_LIMIT name=GXP0001 inuse=1
        [Feb 11 12:15:55] NOTICE[14606]: chan_sip.c:5253 update_call_counter: DEC_CALL_LIMIT name=GXP0001 inringing=0
        == Spawn extension (macro-procexten, s, 24) exited non-zero on 'SIP/8512-b6d8af30' in macro 'procexten'
        == Spawn extension (trusted, 8512, 1) exited non-zero on 'SIP/8512-b6d8af30'
        == Extension Changed 8512[BLF_Group_1] new state InUse for Notify User GXP0003
        == Extension Changed 8512[BLF_Group_1] new state InUse for Notify User GXP0002
        == Extension Changed 8512[BLF_Group_1] new state InUse for Notify User GXP0004
        == Extension Changed 8512[BLF_Group_1] new state InUse for Notify User GXP0001
        == Extension Changed 8512[BLF_Group_1] new state InUse for Notify User GXP0005

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 174844

        U trunk/main/channel.c

        ------------------------------------------------------------------------
        r174844 | file | 2009-02-11 08:44:47 -0600 (Wed, 11 Feb 2009) | 10 lines

        Tell the device state core a change happened when a channel is freed but not a specific state.
        We need to do this because while we know that the freeing of the channel may cause something to become
        not in use we do not know this for sure. There may be another channel that is still up which would cause
        it to be in use.
        (closes issue ASTERISK-12521)
        Reported by: kowalma
        Patches:
        20090121__bug13238.diff.txt uploaded by Corydon76 (license 14)
        Tested by: alecdavis

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=174844

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 174845

        _U branches/1.6.0/

        ------------------------------------------------------------------------
        r174845 | file | 2009-02-11 08:45:24 -0600 (Wed, 11 Feb 2009) | 16 lines

        Blocked revisions 174844 via svnmerge

        ........
        r174844 | file | 2009-02-11 10:44:47 -0400 (Wed, 11 Feb 2009) | 10 lines

        Tell the device state core a change happened when a channel is freed but not a specific state.
        We need to do this because while we know that the freeing of the channel may cause something to become
        not in use we do not know this for sure. There may be another channel that is still up which would cause
        it to be in use.
        (closes issue ASTERISK-12521)
        Reported by: kowalma
        Patches:
        20090121__bug13238.diff.txt uploaded by Corydon76 (license 14)
        Tested by: alecdavis
        ........

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=174845

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 174846

        _U branches/1.6.1/
        U branches/1.6.1/main/channel.c

        ------------------------------------------------------------------------
        r174846 | file | 2009-02-11 08:46:14 -0600 (Wed, 11 Feb 2009) | 17 lines

        Merged revisions 174844 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/trunk

        ........
        r174844 | file | 2009-02-11 10:44:47 -0400 (Wed, 11 Feb 2009) | 10 lines

        Tell the device state core a change happened when a channel is freed but not a specific state.
        We need to do this because while we know that the freeing of the channel may cause something to become
        not in use we do not know this for sure. There may be another channel that is still up which would cause
        it to be in use.
        (closes issue ASTERISK-12521)
        Reported by: kowalma
        Patches:
        20090121__bug13238.diff.txt uploaded by Corydon76 (license 14)
        Tested by: alecdavis
        ........

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=174846


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development