Asterisk
  1. Asterisk
  2. ASTERISK-13176

[patch] "pri_find_dchan: No D-channels available!" error on console when using wcb4xxp

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/chan_dahdi
    • Labels:
      None
    • SVN Revision Number:
      160386
    • Mantis ID:
      14031
    • Regression:
      No

      Description

      When a wcb4xxp is connected as a BRI span in TE mode, you get errors like:

      [Dec 2 22:02:48] WARNING[4759]: chan_dahdi.c:3008 pri_find_dchan: No D-channels available! Using Primary channel 6 as D-channel anyway!
      [Dec 2 22:02:49] WARNING[4758]: chan_dahdi.c:3008 pri_find_dchan: No D-channels available! Using Primary channel 3 as D-channel anyway!
      [Dec 2 22:03:19] WARNING[4759]: chan_dahdi.c:3008 pri_find_dchan: No D-channels available! Using Primary channel 6 as D-channel anyway!

      On your asterisk console and in your asterisk log.

      1. 01-bri_l1_check.patch
        2 kB
        Shaun Ruffell
      2. 20080317_chan_dadhi.diff
        2 kB
        snuffy
      3. bt.txt
        55 kB
      4. intense-ssabme.txt
        39 kB
      5. ssabme.txt
        13 kB
      6. TEIASSIGNMENT.txt
        11 kB

        Issue Links

          Activity

          Jegor added a comment -

          Hello,

          I have installed libpri 1.4.11.5 DAHDI Complete 2.4.1.2+2.4.1 and Asterisk 1.8.3.2
          And I have the same problem.

          But I have tried to downgrade it to libpri 1.4.10.2 and after all compilations chan_dahdi cannot suport BRI at all. In verbose I can see error than signaling bri_cpe is unknown.

          Maybe somebody knows how to recompile all modules for asterisk correctly ?

          Nickilo ( ThinkroSystem) added a comment -

          Hello,

          I have the same problem.

          As jpvis said, it's impossible to build asterisk 1.8 with libpri 1.4.10.2.

          I'm gonna try with libpri svn 1177, which is the first building with asterisk 1.8.

          I think it's a major issue, because we cannot use asterisk 1.8.

          puzzled added a comment -

          FYI: today (May 11, 2012) Digium's Kevin P. Fleming reported the following on the Asterisk mailing list: "There are patches in the works already (being tested by users in Europe) to deal with this layer 1 issue. Upcoming releases of DAHDI and Asterisk should have support for it.".

          Richard Mudgett added a comment -

          See commits for chan_dahdi layer1_presence option:
          -r362430 Asterisk trunk
          -r362429 Asterisk v10
          -r362428 Asterisk v1.8
          -r10661 and -r10662 DAHDI linux/trunk

          Richard Mudgett added a comment -

          The chan_dahdi layer1_presence option is the fix for Asterisk. The DAHDI commits mentioned above help with starting layer 1 as needed.


            Dates

            • Created:
              Updated:
              Resolved:

              Development