Asterisk
  1. Asterisk
  2. ASTERISK-13811

Asterisk using 100% of cpu on 64 bit ubuntu

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Resources/General
    • Labels:
      None
    • Mantis ID:
      14732
    • Regression:
      No

      Description

      I have installed asterisk 1.4.24 on ubuntu 8.10, 64 bit with SMP kernal

      Linux XXXX 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux

      My is SIP/IAX only solution so I do not load any hardware card drivers. I do load dahdi_dummy.
      When using asterisk 1.4.24, cpu usage is constantly around 100% with no calls in progress. I can't see anything on CLI apart from usual registrations. I then installed 1.4.22 with everything else same and cpu usage is down to 0% when idle.
      Everything else is same (same addons, same extensions and same trunks).

      If there is any additional info is needed I can do that.

        Activity

        Leif Madsen added a comment -

        Just reassigned this to dvossel to take a look at this issue to try and determine if there is something in chan_iax2 domain lookups that could cause this. Additionally, if you (dvossel) have any other ideas of how to get debugging information that would be useful, then that would be appreciate.

        To the reporter: this is a low priority issue currently, so thank you for your continued patience on this issue.

        David Vossel added a comment -

        Hey, I looked over this issue a bit and I'm not sure what is causing it. Based on the gdb output I do believe it involves IAX, but I can't tell what it could be doing that consumes 100% cpu.

        There are a few things you could look into that might provide us a clue. In the gdb output, the only active thread is the IAX network thread and it seems to be reading packets. I know you don't have any calls going, but try a packet capture on UDP port 4569 (IAX's port) and see what you get. Some cli debug output may be useful as well.

        If the issue is as simple as starting Asterisk to reproduce, the easiest thing would be to provide access to the system so I could isolate what part of the code is causing it. Email me the information if you are able to do this.

        hoolahoous added a comment -

        Sorry for late response. i might not be able to give you access to my server. But do you think it could be related to bug 14717 ?

        David Vossel added a comment -

        Yes, it may have to do with 14717. If you are able to upgrade, it is worth upgrading to 1.4.25.1 and seeing if you still have a problem.

        David Vossel added a comment -

        As it is, I can't reproduce this or move it forward without additional information. Feel free to reopen if you were able to update and can provide any of the additional information requested.


          People

          • Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development