Asterisk
  1. Asterisk
  2. ASTERISK-13935

[patch] Add support in Asterisk 1.4.24 for Bri cards (Digium B410P - wcb4xxp)

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Mantis ID:
      14871
    • Regression:
      No

      Description

      Simply ported from 1.6.x chan_dahdi signalling for BRI cards. It works in my tests

                • ADDITIONAL INFORMATION ******

      Added a diff file for testing purposes

        Activity

        Ronald Chan added a comment -

        odicha,

        Backporting such change in 1.4.x branch / release is not allowed since, 1.4 branch is in feature freeze state.

        FYI

        Elio added a comment -

        I don't believe it was a new feature, really it's a fix about a support that don't works ever.
        ISDN BRI cards were supported in the moment that DAHDI was released into Asterisk 1.4, but it fails because chan_dahdi don't support BRI signalling, so now we have two possibilities: a very poor support of isdn cards with mISDN drivers (with a lot of errors with actual version of Linux kernels) or DAHDI with wcb4xxp that looks like works fine.

        Ronald Chan added a comment -

        I stand corrected, if this was truly a fix then let us hope, a developer will pick this up.

        Leif Madsen added a comment -

        Closing this per Qwell on IRC; this is not a candidate for Asterisk 1.4, but this patch is still available here for anyone who wishes to use it out of band. Thanks for your work and the contribution, but we cannot put this into the 1.4 branch of Asterisk.

        Thanks!


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development