Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Mantis ID:
      1429
    • Regression:
      No

      Description

      There's a lot of patches for saying numbers around here. We need to unify them and fix a general solution. This bug is for the unification of several other bug reports.

      The way we're handling this is

      • First a quick fix to say.c to say numbers with various
        language syntaxes supported
      • Add sample sound files and documentation
      • Start working on a general language-support architecture
        with loadable modules and support for more
        functions, like date, time and various strings

      ------------------- * -----------------------
      If you want to follow the progress, press "Monitor bug" below.
      ------------------- * -----------------------

                • ADDITIONAL INFORMATION ******

      Bug 0001097 Other languages
      Bug 0001372 French - disclaimed
      Bug 0001349 Danish - disclaimed
      Bug 0000300 Portuguese - disclaimed
      Bug 0000237 Spanish - disclaimed
      Italian - disclaimed

      Swedish and Norwegian works as English. Any other languages that does not work as english?

      ------
      Spanish requires these additional sound files:

      • 21.gsm thru 29.gsm, cien.gsm, mil.gsm, millon.gsm
      • millones.gsm, 100.gsm, 200.gsm, 300.gsm, 400.gsm,
      • 500.gsm, 600.gsm, 700.gsm, 800.gsm, 900.gsm, y.gsm
        ------
        Portuguese:
      • All files that ends with "F" are feminine
        ------
        Danish:
        In addition to English, the following sounds are required: "millions", "and" and "1-and" through "9-and"
      1. 0001429-i18n.testsuite.conf
        3 kB
      2. 0001429-itsounds.tar.gz
        156 kB
      3. 0001429-READMEs.tar.gz
        0.7 kB
      4. 0001429-say_da.diffdiff
        2 kB
      5. 0001429-say_da.txt
        16 kB
      6. 0001429-say_intl.txt
        52 kB
      7. 0001429-say.es.txt
        4 kB
      8. 0001429-say.patch
        46 kB

        Activity

        flavour added a comment -

        Updated i18n.testsuite.conf attached - broken into seperate extensions to call to test each language & more examples put in, although there are still more to go in.
        My testing so far shows a problem with Portuguese (other than the continued lack of available soundfiles )
        SayNumber(183) fails to find '100E', then 'pt-e' (which seems to be a duplication) & then doesn't bother with the '83' at all...

        philipp2 added a comment -

        Short note: I hope (this is not a promise, though) to be able to provide German sound files soon.

        c960657 added a comment -

        All languages appear to be missing 0.gsm.

        There seems to be some inconsistency whether the files for "hundred", "thousand" etc. should be named in English, in the local language or in digits (e.g. 1000.gsm).

        As mentioned above, I am no expert in German, but if the current implementation uses (almost) the same rules as Danish, the required files should be the same, including the "1-and" sounds. I don't know if "1-and" through "9-and" are required in German - perhaps "1" through "9" followed by "and" is sufficient.

        There is a README file for Swedish (se), but not for Norwegian (no), though they both use the same syntax.

        In the code, Swedish and Norwegian currently use the same rules as English. However, both these languages use gender, very similar Danish. Actually, they speak two different languages in Norway (nynorsk and bokmål). I don't know how similar they are.

        The patch only mentions the option in relation to gender in Portuguese. Gender is also relevant for Danish, Swedish, Norwegian, German, French and possibly other languages. In addition to Portuguese, at least the Danish code properly supports gender.

        The support for some languages may not be perfect, but at least some is better than nothing. So I am not arguing that the code should not go in.

        mmenaz added a comment -

        As promised, I've uploaded the complete Italian sounds set (bug # 1514). Now there must be coordination between the italian code developers and the sound recorders. Since I use my wife's voice, I can catch up with coders need very fast and with "low cost" (only my and my wife's time). BTW, producing those files I've understand why professional recordings are so expensive
        When/if mbrancaleoni's company will give the full set of sounds to the community, italians will have the luxury of 2 voices to choose from! Fabolous
        I've disclaimed to digium 3 days ago.

        Mark Spencer added a comment -

        Merged in CVS


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development