Asterisk
  1. Asterisk
  2. ASTERISK-14510

[patch] SIP_BODY function to get a body part of a SIP message

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Suspended
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Functions/NewFeature
    • Labels:
      None
    • Source Revision Number:
      206090
    • Mantis ID:
      15552
    • Regression:
      No

      Description

      this patch adds the function SIP_BODY for chan_sip to get a body part by its Content-Type. Therefore, the existing find_sdp() is generalized to find_content() and find_sdp() calls find_content() with the parameter "application/sdp".

      usage example: $

      {SIP_BODY(application/pidf+xml)}

      to get a PIDF document from the SIP body.

        Issue Links

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          khw added a comment -

          If just uploaded a new version. This patch now allows to get a body part as proposed by klaus3000: SIP_BODY(contenttype[,n])
          In order to get the second PIDF-LO in the body, one could use:

          SIP_BODY(application/pidf+xml,2)

          I hope this is a useful extension.

          Leif Madsen added a comment -

          OK, looks good! Just need some testing and reviewers eyes I guess, then we can move this into trunk.

          klaus3000 added a comment -

          Looks like this enhancement was forgotten. Should we put it on the reviewboard?

          Marco Marzetti added a comment -

          Please, put it in reviewboard!
          Thank You

          Corey Farrell added a comment -

          As far as I can tell the patches were never posted for review and they no longer apply cleanly so I'm suspending this ticket.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: