Asterisk
  1. Asterisk
  2. ASTERISK-14536

[patch] Comfort noise frame with f->data NULL but f->datalen 160

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/General
    • Labels:
      None
    • Mantis ID:
      16242
    • Regression:
      No

      Description

      Asterisk crashed, and the last message was:
      [Nov 13 11:19:11] NOTICE[31951] rtp.c: Comfort noise support incomplete in Asterisk (RFC 3389). Please turn off on client if possible. Client IP: 10.6.11.241

                • ADDITIONAL INFORMATION ******

      Version is 1.6.0.16-rc2

      1. cng-crash-backtrace.txt
        71 kB
      2. comfort.pcap
        2 kB
      3. issue16242.diff
        0.4 kB
        Olle Johansson

        Issue Links

          Activity

          Digium Subversion added a comment -

          Repository: asterisk
          Revision: 231505

          _U branches/1.6.2/
          U branches/1.6.2/main/rtp.c

          ------------------------------------------------------------------------
          r231505 | dvossel | 2009-11-30 11:38:41 -0600 (Mon, 30 Nov 2009) | 24 lines

          Merged revisions 231491 via svnmerge from
          https://origsvn.digium.com/svn/asterisk/trunk

          ................
          r231491 | dvossel | 2009-11-30 11:28:28 -0600 (Mon, 30 Nov 2009) | 17 lines

          Merged revisions 231441 via svnmerge from
          https://origsvn.digium.com/svn/asterisk/branches/1.4

          ........
          r231441 | dvossel | 2009-11-30 11:14:08 -0600 (Mon, 30 Nov 2009) | 11 lines

          fixes crash caused by RTP comfort noise payload greater than 24 bytes

          AST-2009-010

          (closes issue ASTERISK-14536)
          Reported by: amorsen
          Patches:
          issue16242.diff uploaded by oej (license 306)
          Tested by: amorsen, oej, dvossel
          ........
          ................

          ------------------------------------------------------------------------

          http://svn.digium.com/view/asterisk?view=rev&revision=231505

          Digium Subversion added a comment -

          Repository: asterisk
          Revision: 231512

          _U branches/1.6.1/
          U branches/1.6.1/main/rtp.c

          ------------------------------------------------------------------------
          r231512 | dvossel | 2009-11-30 11:40:35 -0600 (Mon, 30 Nov 2009) | 24 lines

          Merged revisions 231491 via svnmerge from
          https://origsvn.digium.com/svn/asterisk/trunk

          ................
          r231491 | dvossel | 2009-11-30 11:28:28 -0600 (Mon, 30 Nov 2009) | 17 lines

          Merged revisions 231441 via svnmerge from
          https://origsvn.digium.com/svn/asterisk/branches/1.4

          ........
          r231441 | dvossel | 2009-11-30 11:14:08 -0600 (Mon, 30 Nov 2009) | 11 lines

          fixes crash caused by RTP comfort noise payload greater than 24 bytes

          AST-2009-010

          (closes issue ASTERISK-14536)
          Reported by: amorsen
          Patches:
          issue16242.diff uploaded by oej (license 306)
          Tested by: amorsen, oej, dvossel
          ........
          ................

          ------------------------------------------------------------------------

          http://svn.digium.com/view/asterisk?view=rev&revision=231512

          Digium Subversion added a comment -

          Repository: asterisk
          Revision: 231517

          _U branches/1.6.0/
          U branches/1.6.0/main/rtp.c

          ------------------------------------------------------------------------
          r231517 | dvossel | 2009-11-30 11:41:43 -0600 (Mon, 30 Nov 2009) | 24 lines

          Merged revisions 231491 via svnmerge from
          https://origsvn.digium.com/svn/asterisk/trunk

          ................
          r231491 | dvossel | 2009-11-30 11:28:28 -0600 (Mon, 30 Nov 2009) | 17 lines

          Merged revisions 231441 via svnmerge from
          https://origsvn.digium.com/svn/asterisk/branches/1.4

          ........
          r231441 | dvossel | 2009-11-30 11:14:08 -0600 (Mon, 30 Nov 2009) | 11 lines

          fixes crash caused by RTP comfort noise payload greater than 24 bytes

          AST-2009-010

          (closes issue ASTERISK-14536)
          Reported by: amorsen
          Patches:
          issue16242.diff uploaded by oej (license 306)
          Tested by: amorsen, oej, dvossel
          ........
          ................

          ------------------------------------------------------------------------

          http://svn.digium.com/view/asterisk?view=rev&revision=231517

          Digium Subversion added a comment -

          Repository: asterisk
          Revision: 231518

          U branches/1.2/rtp.c

          ------------------------------------------------------------------------
          r231518 | dvossel | 2009-11-30 11:43:14 -0600 (Mon, 30 Nov 2009) | 10 lines

          fixes crash caused by RTP comfort noise payload greater than 24 bytes

          AST-2009-010

          (closes issue ASTERISK-14536)
          Reported by: amorsen
          Patches:
          issue16242.diff uploaded by oej (license 306)
          Tested by: amorsen, oej, dvossel

          ------------------------------------------------------------------------

          http://svn.digium.com/view/asterisk?view=rev&revision=231518

          Olle Johansson added a comment -

          I found no crash issue with 1.4 though - did you?


            People

            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development