Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Suspended
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Mantis ID:
      16014
    • Regression:
      No

      Description

      Hi,

      I have a problem with one call scenario on my Asterisk server.
      The call is coming from an external SIP proxy to my server. Asterisk sends the call to one internal extension.
      Extension rings and then answers.
      The user at extension hears audio for 0.5 seconds. Then audio in that direction is cut. (no RTP is sent)
      Audio in other direction continues.

      I got network traces for this call scenario. Everything seems normal in SIP messaging and as RTP.
      I can also see that external audio continues even after the internal extension's audio is cut.

      This problem occurs with one type of CPE on the external side. With other CPEs this problem is not reproduced.

      I believe Asterisk cuts the internal extension's audio because it doesn't like something in the RTP stream of external CPE.

      I will add the network trace for unsuccessful call together with RTP debug on Asterisk.
      On both of these files it is clearly seen that one way audio is cut in a very short time after call is established.

                • ADDITIONAL INFORMATION ******

      The Asterisk server has 2 interfaces (ppp0 to WAN, and br0 to LAN)
      So internal clients reach the Asterisk on br0 interface and Asterisk reaches the external proxy through ppp0.

      In the network trace IP addresses are:

      192.168.254.254 : Asterisk server LAN address
      192.168.254.5 : Extension 995 in LAN , Linksys SPA 3000
      95.65.180.146 : Asterisk server WAN address
      193.243.202.97 : External SIP Proxy
      193.243.202.124 : SIP Proxy RTP address

      1. agi_fail.txt
        19 kB
      2. all_sip_conf.txt
        5 kB
      3. audio-problem.cap
        137 kB
      4. rtp_debug.txt
        13 kB
      5. trace.txt
        154 kB

        Issue Links

          Activity

          ilker Aktuna added a comment -

          denke and lmadsen,

          thanks for your answers. I understand that the issue will be checked by a developer when they have time. however, I am having problems because of the issue and now that I solved the VAD issue by using g711 on internal clients, the issue is totally different. (some calls are not reaching the internal clients)
          So, should I open a new bug file or will this be enough to follow up ?

          And, meanwhile what can I do to solve my problem ?
          How can I not understand why it is occuring ? There must be a log to see why the call is not reaching the extensions. Am I wrong ?

          Denes Dolhay added a comment -

          You should probably open another bug report, unless you suspect, that this problem is originated from the same bug.

          You can find out what asterisk is doing by settig the information level on the console to debug (I think you can do this in asterisk.conf) and increasing the debug level (ex.: core set debug 100), and if you stil don't have what your searching for, then you should enable sip debug as well.

          Leif Madsen added a comment -

          I agree with denke, if the issue originally associated with this issue is resolved, then I'm going to close this issue, and any further issues should be followed up by another report.

          The issue tracker is not a support system, and thus your questions are most appropriate for the asterisk-users list, or #asterisk-users IRC channel on irc.freenode.net.

          ilker Aktuna added a comment -

          I didn't say that the original issue is solved.
          Original issue is solved by selecting different codec in the internal clients.
          But I prefer not using any transcoding (and common sense says so). That's why original issue remains.

          Joshua Colp added a comment -

          Per the Asterisk versions page [1], the maintenance (bug fix) support for the Asterisk branch you are using has ended. For continued maintenance support please move to a supported branch of Asterisk. After testing with a supported branch, if you find this problem has not been resolved, please open a new issue against the latest version of that Asterisk branch.

          Thanks!

          [1] https://wiki.asterisk.org/wiki/display/AST/Asterisk+Versions


            People

            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development