Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Applications/General
    • Labels:
      None
    • Mantis ID:
      156
    • Regression:
      No

      Description

      This patch adds several enhanced features to Comedian Mail. These features include:

      • Recording options: cancel and call operator
      • End-of-recording options: accept, review, re-record
      • Maintenance options: removal of short and silent messages
      • Advanced options: call back, reply, envelope, outcall
      • Temporary greetings
      • Navigation options: jump to first/last message
      • Access options: log into mailbox during greeting

      I've attached a tar file with the patch, prompts, and instructions

                • ADDITIONAL INFORMATION ******

      Voice Prompts

      • The necessary voice prompts are included, but in my voice

      Caveats

      • The Call Back and Outgoing Call features will not work correctly unless careful consideration is given to ensure that extension, mailbox, and Caller ID number formats match in the extensions.conf and voicemail.conf files
      • There is currently no mechanism to ensure that messages are not available for playback (by the recipient) while they are still being reviewed (by the sender). In exceptional circumstances, this could result in a message being heard by the recipient and subsequently erased by the sender.
      • I haven't taken advantage of the recent enhancements for fancy time/date for the purposes of the message envelope function
      • At one point I had made the context for outgoing calls and the removal of very short and silent messages a configurable option, but foolishly deleted that modification, so for now these options are not configurable

        Activity

        hwstar added a comment -

        1. fixed_advanced7.diff does indeed fix the segfault. Thanks twisted!

        2. I was able to duplicate the issue raised by Murf. But only
        when I dialed some numeric digits before I pressed the * key.
        Pressing '*' before dialing any digits does abort the call request.
        I suppose we could search the dial string for an * and abort the call
        as well. Comments on this?

        edited on: 04-21-04 21:42

        bradster added a comment -

        Hmm... its interesting what you don't think of in advance.

        I suppose we should search for the * anywhere in the string and abort the call. The problem with this is that you would have to press *, and then wait for the timeout, because you wouldn't (well, your average user wouldn't) think to press * then # to end the string.

        hwstar added a comment -

        Why not lose the '*' option, and say "dial your number and press # to connect your call, or press # now to abort".

        Steve.

        edited on: 04-22-04 11:53

        bradster added a comment -

        Yeah I was thinking that... but then I'm not sure what makes for the most consistent experience from the end user's perspective about when to use * and #. But that's a whole other story. # to cancel is probably good for now. I'll try to get that done on the weekend and get a new bug report created as well.

        twisted added a comment -

        Moved to 1483 to keep Mantis from blowing up, and to make it easier to manage this.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development