Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Documentation
    • Labels:
      None
    • SVN Revision Number:
      231692
    • Mantis ID:
      16505
    • Regression:
      No

      Description

      The man page included with Asterisk is outdated. Does not include a number of options.

      There is also doc/asterisk.sgml . It has been updated once or twice in the past. I don't see any Makefile target to generate a man page from it.

      Furthermore, to reference a recent Debian bug: the man page is supposed to also be used as a man page for rasterisk, but does not mention it.

      Likewise undocumented is the ASTERISK_PROMPT variable.

      1. 20091228__issue16505__3.diff.txt
        10 kB
        Tilghman Lesher
      2. asterisk_sgml_fixes_demo.diff
        4 kB
        Tzafrir Cohen
      3. manpages.diff
        31 kB
        Andrew Latham
      4. new_asterisk.8
        9 kB
        Andrew Latham

        Activity

        Leif Madsen added a comment -

        Right, but what I'm saying is why bother updating the manpages at all when all documentation should be shifted to the wiki, instead of having the same documentation in two locations?

        Andrew Latham added a comment -

        Because some distros, like Debian require a manpage for every program.

        Andrew Latham added a comment -

        Uploaded a more complete diff. The sgml and Makefile can be removed. If people want to keep the sgml and Makefile they should delete the man page. It is silly to have both. I also started updating the manpages in /contrib/scripts/ the documentation on the IAX RSA is missing from the wiki but exists on voip-info.

        Andrew Latham added a comment -

        Can this be looked at for 1.10 or do I need to do the review board for this?

        Andrew Latham added a comment -

        Lack of interest


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development