Asterisk
  1. Asterisk
  2. ASTERISK-15573

[patch] T.38 negotiation fails with Patton SN2400

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/chan_sip/T.38
    • Labels:
      None
    • Source Revision Number:
      244639
    • Mantis ID:
      16766
    • Regression:
      No

      Description

      Patton SN2400 refuses to negotiate T.38 session because of extra newline in SDP.

      [Feb 3 22:31:46] DEBUG[31017] chan_sip.c: Body 5 [ 22]: m=image 4326 udptl t38
      [Feb 3 22:31:46] DEBUG[31017] chan_sip.c: Body 6 [ 0]:
      [Feb 3 22:31:46] DEBUG[31017] chan_sip.c: Body 7 [ 17]: a=T38FaxVersion:0

      proposed fix:
      — asterisk.orig/channels/chan_sip.c 2010-02-03 23:52:03.000000000 +0200
      +++ asterisk/channels/chan_sip.c 2010-02-03 23:58:41.000000000 +0200
      @@ -9191,8 +9191,6 @@ static enum sip_result add_sdp(struct si
      ast_str_append(&m_video, 0, "\r\n");
      if (needtext)
      ast_str_append(&m_text, 0, "\r\n");

      • if (add_t38)
      • ast_str_append(&m_modem, 0, "\r\n");

      len = strlen(version) + strlen(subject) + strlen(owner) +
      strlen(connection) + strlen(session_time);

        Issue Links

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          Raivis Rengelis added a comment -

          i already tested before reporting the bug and yes, it fixes it. (just uploaded full sip/sdp debug log that was failing)

          Raivis Rengelis added a comment -

          yes, the second one should work as well. I just did not dwell into why original author went one way for audio/video/text and different way for t38. anyways both of those patches fix the problem with pattons and possibly other gateways.

          Raivis Rengelis added a comment -

          btw, redundant \r\n was introduced in revision 243860, if that matters.

          Digium Subversion added a comment -

          Repository: asterisk
          Revision: 245727

          U trunk/channels/chan_sip.c

          ------------------------------------------------------------------------
          r245727 | mnicholson | 2010-02-09 11:40:04 -0600 (Tue, 09 Feb 2010) | 8 lines

          This commit removes an extra newline in T.38 generated SDP packets. This bug was caused by the fix introduced in r243860.

          (closes issue ASTERISK-15573)
          Reported by: raivisr
          Patches:
          t38-sdp-newline-fix1.diff uploaded by mnicholson (license 96)
          Tested by: raivisr

          ------------------------------------------------------------------------

          http://svn.digium.com/view/asterisk?view=rev&revision=245727

          Digium Subversion added a comment -

          Repository: asterisk
          Revision: 245728

          _U branches/1.6.2/
          U branches/1.6.2/channels/chan_sip.c

          ------------------------------------------------------------------------
          r245728 | mnicholson | 2010-02-09 11:43:41 -0600 (Tue, 09 Feb 2010) | 15 lines

          Merged revisions 245727 via svnmerge from
          https://origsvn.digium.com/svn/asterisk/trunk

          ........
          r245727 | mnicholson | 2010-02-09 11:40:04 -0600 (Tue, 09 Feb 2010) | 2 lines

          This commit removes an extra newline in T.38 generated SDP packets. This bug was caused by the fix introduced in r243860.

          (closes issue ASTERISK-15573)
          Reported by: raivisr
          Patches:
          t38-sdp-newline-fix1.diff uploaded by mnicholson (license 96)
          Tested by: raivisr
          ........

          ------------------------------------------------------------------------

          http://svn.digium.com/view/asterisk?view=rev&revision=245728


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: