Asterisk
  1. Asterisk
  2. ASTERISK-16626

DTMF not logged to console when configured in logger.conf

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      17922
    • Regression:
      No

      Description

      duplicate issue of 0017043, except I am using the latest version of the 1.6.2 line of Asterisk compiled from source.

      DTMF works correctly; I can see the packets when I tcpdump. I just never see any DTMF related information on the console.

      pbx1> grep -i dtmf /etc/asterisk/logger.conf
      ; dtmf
      console => notice,warning,error,dtmf
      pbx1> suex /etc/init.d/asterisk stop
      pbx1> ps -ef | grep asterisk
      jkister 2359 1598 0 22:50 pts/2 00:00:00 grep asterisk
      pbx1> suex /etc/init.d/asterisk start
      pbx1> suex asterisk -r
      Asterisk 1.6.2.11, Copyright (C) 1999 - 2010 Digium, Inc. and others.
      Created by Mark Spencer <markster@digium.com>
      Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
      This is free software, with components licensed under the GNU General Public
      License version 2 and other licenses; you are welcome to redistribute it under
      certain conditions. Type 'core show license' for details.
      =========================================================================
      Connected to Asterisk 1.6.2.11 currently running on pbx1 (pid = 2272)
      Verbosity is at least 3
      pbx1*CLI> core set debug 5
      Core debug was 0 and is now 5
      pbx1*CLI> core set verbose 5
      Verbosity was 3 and is now 5
      pbx1*CLI> logger show channels
      Channel Type Status Configuration
      ------- ---- ------ -------------
      /var/log/asterisk/messages File Enabled - Warning Notice Error
      Console Enabled - DTMF Warning Notice Error
      pbx1*CLI>
      pbx1*CLI>
      == Using SIP RTP CoS mark 5
      == Using SIP VRTP CoS mark 6
      == Using UDPTL CoS mark 5
      – Executing [8008374966@extensions:1] Set("SIP/101-00000006", "CALLERID(all)=The Kisters <0005551212>") in new stack
      – Executing [8008374966@extensions:2] Macro("SIP/101-00000006", "SaferSIPDial,8008374966") in new stack
      – Executing [s@macro-SaferSIPDial:1] Set("SIP/101-00000006", "DIALTRIES=1") in new stack
      – Executing [s@macro-SaferSIPDial:2] GotoIf("SIP/101-00000006", "0?unavail") in new stack
      – Executing [s@macro-SaferSIPDial:3] Set("SIP/101-00000006", "SIPSERVER=vgw1") in new stack
      – Executing [s@macro-SaferSIPDial:4] GotoIf("SIP/101-00000006", "1?preroute") in new stack
      – Goto (macro-SaferSIPDial,s,10)
      – Executing [s@macro-SaferSIPDial:10] Set("SIP/101-00000006", "PREROUTE=9930") in new stack
      – Executing [s@macro-SaferSIPDial:11] GotoIf("SIP/101-00000006", "1?dial") in new stack
      – Goto (macro-SaferSIPDial,s,15)
      – Executing [s@macro-SaferSIPDial:15] NoOp("SIP/101-00000006", ""Dialing SIP/99308008374966@vgw1 - try 1"") in new stack
      – Executing [s@macro-SaferSIPDial:16] Dial("SIP/101-00000006", "SIP/99308008374966@vgw1") in new stack
      == Using SIP RTP CoS mark 5
      == Using SIP VRTP CoS mark 6
      == Using UDPTL CoS mark 5
      – Called 99308008374966@vgw1
      – SIP/vgw1-00000007 is making progress passing it to SIP/101-00000006
      – SIP/vgw1-00000007 answered SIP/101-00000006
      == Spawn extension (macro-SaferSIPDial, s, 16) exited non-zero on 'SIP/101-00000006' in macro 'SaferSIPDial'
      == Spawn extension (extensions, 8008374966, 2) exited non-zero on 'SIP/101-00000006'
      pbx1*CLI>

      I entered lots of DTMF going through Verizon's Automated Attendant Hell. The DTMF was received by verizon just fine but nothing DTMF related logged to my console

                • ADDITIONAL INFORMATION ******

      I'm happy to give an Asterisk admin/coder ssh access to the box as well as configure a remote sip client for debugging.

      1. IMG_0003.mpg
        1.79 MB
      2. sip.txt
        6 kB

        Issue Links

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          Vladimir Mikhelson added a comment -

          luckman212: I am positive as I could be as it works as expected now.

          I did restart Asterisk multiple times, and it did not break the DTMF console logging for me. I have not rebooted the box ever since 05/07 though.

          One thought. I am not seeing DTMF in any SSH sessions, I do not believe I ever did. I do see DTMF logging in the real console after 1.8.4 was installed.

          -Vladimir

          Luke H added a comment -

          Hmm. I didn't know there was any difference between running 'asterisk -r' from a local console vs. an SSH session. This is news to me. And I do see the DTMF logged via SSH but only after issuing 'logger set level dtmf OFF'

          Vladimir Mikhelson added a comment -

          As I said, I never observed DTMF logging active in SSH sessions and kind of assumed it was by design.

          I have verified the 'logger set level dtmf OFF' turns DTMF logging on in a SSH session, and 'logger set level dtmf ON' turns it off.

          As we are on this topic. There are other circumstances when an output is only visible on the local console. Take a look here for an example: https://issues.asterisk.org/view.php?id=18847

          -Vladimir

          Jeremy Kister added a comment -

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: