Asterisk
  1. Asterisk
  2. ASTERISK-17055

[patch] outbound google voice calls fail (staring approx 30Nov2010)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/chan_gtalk
    • Labels:
      None
    • Mantis ID:
      18412
    • Regression:
      No

      Description

      Looks like something changed on google's side a couple days ago. Incoming calls still work but all outbound calls fail with "Remote peer reported an error, trying to establish the call anyway."

      Verified on two installs and with a couple people on #asterisk irc.

        Issue Links

          Activity

          Brandon Hunt added a comment -

          calls to buddies complete, so the issue is only related to pstn calls, attached xml snippets suggest that something has changed with the pstn syntax

          Jon C. added a comment -

          pstn dailing out is not going through. it started yesterday 12-01-2010

          Mario Limonciello added a comment -

          i double checked with a wireshark capture from the official client, and it's still using +1NXXNXXXXXX@voice.google.com syntax. Fails the same with both +1NXXNXXXXXX@voice.google.com and 1NXXNXXXXXX@voice.google.com

          Mario Limonciello added a comment -

          I'm not sure how timely a fix will be showing up. In the interim for those who come here hitting this problem, i've detailed a workaround using an AGI callback mechanism that will hit back gtalk at http://supermario-world.blogspot.com/2010/12/nov-30th-break-of-asterisk-18-w-gv.html

          az1324 added a comment -

          This is a protocol issue. Not too difficult of a fix. Log file attached showing differences.

          Maybe whoever patches it can also enable invisibility as per: http://chinmaykamat.wordpress.com/2010/01/22/google-talk-invisible-mode-in-pidgin/

          Brandon Hunt added a comment -

          After looking at the notes from az1324 and doing some more debugging, it looks like the problem is that we need to omit the /srvres portion of the "to" attribute on the first invite. After they send back the redirect we need to pull the /srvres-ID portion and append that to our "to" before sending the candidates packet.

          David Vossel added a comment -

          uploaded a patch that will fix it.

          We had to get the srvres-ID portion from the redirect and then re-initiate the call using the new ID.

          Digium Subversion added a comment -

          Repository: asterisk
          Revision: 297957

          U branches/1.8/channels/chan_gtalk.c

          ------------------------------------------------------------------------
          r297957 | dvossel | 2010-12-09 15:32:21 -0600 (Thu, 09 Dec 2010) | 11 lines

          Fixes issue with outbound google voice calls not working.

          Thanks to az1234 and nevermind_quack for their input in helping debug the issue.

          (closes issue ASTERISK-17055)
          Reported by: nevermind_quack
          Patches:
          fix uploaded by dvossel (license 671)

          ------------------------------------------------------------------------

          http://svn.digium.com/view/asterisk?view=rev&revision=297957

          Digium Subversion added a comment -

          Repository: asterisk
          Revision: 297958

          _U trunk/
          U trunk/channels/chan_gtalk.c

          ------------------------------------------------------------------------
          r297958 | dvossel | 2010-12-09 15:33:22 -0600 (Thu, 09 Dec 2010) | 16 lines

          Merged revisions 297957 via svnmerge from
          https://origsvn.digium.com/svn/asterisk/branches/1.8

          ........
          r297957 | dvossel | 2010-12-09 15:32:20 -0600 (Thu, 09 Dec 2010) | 11 lines

          Fixes issue with outbound google voice calls not working.

          Thanks to az1234 and nevermind_quack for their input in helping debug the issue.

          (closes issue ASTERISK-17055)
          Reported by: nevermind_quack
          Patches:
          fix uploaded by dvossel (license 671)
          ........

          ------------------------------------------------------------------------

          http://svn.digium.com/view/asterisk?view=rev&revision=297958


            People

            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development