Asterisk
  1. Asterisk
  2. ASTERISK-17333

[patch] Use of Google XMPP Extensions for Google Talk/Voice

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/chan_gtalk
    • Labels:
      None
    • Mantis ID:
      18727
    • Regression:
      No

      Description

      I know that mod_dingaling is built to work with the XMPP standard, but the primary implementation of the XMPP standard as of right now is Google Talk/Voice. It would be great to integrate some of the functionality that in the Google XMPP extensions into freeswitch so that we could talk advantage of this. I've posted the table below just to give people an idea of what the extensions have available. I got the idea what PSU VoIP blog posted a patch for Asterisk to set invisibility for Google Talk. Right now, it's more of a hack since they implemented it in the res_jabber, but if it was moved into the chan_gtalk, it could be maintained there an not be as much of a hack. I'm willing to put in some work for this and just want some help/advice.

      I have posted this on both the freeswitch and the Asterisk issues just to see if I could get anyone interested. Thanks!

      Extension Description
      User Settings Enables a client to make and query client settings handled by the server.
      Off the Record Chats Enables a client to turn off server-side logging for individual conversations, and alert clients to turn off client-side logging as well.
      Jingle Server Discovery Returns a list of servers that a client can use to connect a Jingle session.
      Gmail Notifications Enables a client to request notifications when their Gmail account receives a new email, or to query for unread emails.
      Shared Status Messages Enables multiple client instances to share a central list of status messages.
      Extended Contact Attributes Sets or retrieves additional information about roster members.
      JID Domain Discovery Enables a client to sign into the Google server using either the gmail.com or googlemail.com domain.
      Voicemail Enables a client to send voicemail messages to other chat clients.

        Issue Links

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          Paul Belanger added a comment -

          Patches welcome

          SLG added a comment -

          The above included path was copied from http://www.personal.psu.edu/wcs131/repos/asterisk/res_jabber.patch. I hold no intellectual property right on the document at all. The poster did open it up for Asterisk development.

          I'm trying to figure out a clean way to get the functionality in that's only controlled by chan_gtalk. Would it be OK/reasonable to create a separate gtalk data struct to have the invisibility in there? I'm just afraid of maintaining any future changes. I thought about looking into libjingle integration, but I don't want to switch from iksemel if its the standard

          Paul Belanger added a comment -

          We cannot include copied patches, they must be submitted by the original licenses holder.

          As for development questions, I suggest using the asterisk-dev mailing list or IRC channel. The issue tracker is not the best place to discuss them.

          billsimon added a comment -

          I have uploaded the patch referenced by stephengroat. It is my own work and was recently posted on my blog, where he saw it. Information including reference materials are at http://www.personal.psu.edu/wcs131/blogs/psuvoip/2011/01/asterisk_hack_make_your_google.html . I do not recommend use of my hack-code except as a starting point to get someone going on the ideas Groat presented.

          Leif Madsen added a comment -

          Great thanks! The next step is likely to move this discussion to the asterisk-dev list and find out how to get some of this implemented and moved forward. Thanks again!

          Matt Jordan added a comment -

          Thank-you for your bug report. As the module this issue is reported against is in extended support [1], development for it primarily comes from the Asterisk developer community. As this module may or may not have an active deveoper, your issue may have a lower level of support as compared to the core modules in Asterisk, and response times may reflect that.

          https://wiki.asterisk.org/wiki/display/AST/Asterisk+Module+Support+States

          Malcolm Davenport added a comment -

          chan_gtalk has been deprecated in newer version of Asterisk. The XMPP support within Asterisk, and connectivity to Google, was completely rewritten as res_xmpp and chan_motif.

          I'm not sure that chan_gtalk is even functional with Google these days. But, if someone wants to carry this forward into chan_gtalk, they're welcome to do so - though looking into Motif may be a better option. In the meantime, I'm going to close this issue as won't fix, because chan_gtalk's deprecated.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: