Asterisk
  1. Asterisk
  2. ASTERISK-1984

[patch] allow the transfer keys from app_dial's 't' and 'T' and hangup key 'H' to be configured via features.conf

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      2010
    • Regression:
      No

      Description

      Don't be afraid, this patch modifies res_features.c, app_dial.c, and updates features.conf.sample.

      This patch allows you to define your keypresses to use inline transfer options to be single, double, or double with configurable timeout. This also allows you to change the hangup key (single key only). This is based on CVS RC1 as of 07/16/04.

                • ADDITIONAL INFORMATION ******

      Enjoy!

        Activity

        cshaw59 added a comment -

        Added a new patch against today's CVS to hold us over until Mark gets time to work on it!

        P.S please ignore the first one, I missed a '/' and it doesn't work....

        Enjoy!

        -Chris

        edited on: 09-17-04 22:16

        Anthony Minessale added a comment -

        see bug 2460 where I have tried to add my own humble implementation
        of this feature to my attended xfer patch..

        Anthony Minessale added a comment -

        cshaw59 sorry i was trying to clean up that
        extra file you had and deleted both by accident =(
        can you put it back thx...

        edited on: 09-20-04 16:45

        cshaw59 added a comment -

        No problem Anthm,

        It'll have to be after I get off work though, about 6:00PST

        twisted added a comment -

        Well... since this never really got the attention from the gods that it deserved, i'm closing it in favor of anthm's attempt on ASTERISK-2425


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development