Asterisk
  1. Asterisk
  2. ASTERISK-211

[patch] Announce callers position in queue every x seconds / service level reporting / queue timeouts / hold time estimation

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Applications/app_queue
    • Labels:
      None
    • Mantis ID:
      214
    • Regression:
      No

      Description

      This patch will announce the callers postition in the call queue every x seconds set by announcefreq in queues.conf or set to 0 to disable it.

        Activity

        jesses added a comment -

        I used the development patch app_queue_patch_1_07a.tar, with todays CVS. If I take the app_queue.c file from the CVS that was put out on the same day as the patch, the patch goes in fine, but when I try to call the queue, I dont hear any announcements and I see this in my logs-

        Mar 12 15:49:02 WARNING[917526]: File "queue-youarenext" does not exist in any format
        Mar 12 15:49:02 WARNING[917526]: Unable to open "queue-youarenext" (format ULAW): No such file or directory
        Mar 12 15:49:02 WARNING[917526]: File "queue-thankyou" does not exist in any format
        Mar 12 15:49:02 WARNING[917526]: Unable to open "queue-thankyou" (format ULAW): No such file or directory

        I am sure that the files are in the right place, I have no idea why it will not find it

        jesses added a comment -

        Nevermind, the queue.conf file had quotes around the filenames for some reason. Removing fixed it. I agree with earlier comments that sound filenames as an option should be removed. I'm proof that it causes more problems then it solves

        edited on: 03-12-04 22:38

        menger added a comment -

        jesses: yeah. I had that issue and fixed it in the queue.conf patch inside 1_07a.

        Mark Spencer added a comment -

        I've merged this into CVS. If there are any bugs related to this, please open a new tracking ticket since this one is sooooo long.

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 2415

        U trunk/CHANGES
        U trunk/Makefile
        U trunk/apps/app_queue.c
        U trunk/configs/queues.conf.sample
        A trunk/sounds/queue-callswaiting.gsm
        A trunk/sounds/queue-holdtime.gsm
        A trunk/sounds/queue-minutes.gsm
        A trunk/sounds/queue-thankyou.gsm
        A trunk/sounds/queue-thereare.gsm
        A trunk/sounds/queue-youarenext.gsm
        U trunk/sounds.txt

        ------------------------------------------------------------------------
        r2415 | markster | 2008-01-15 14:46:58 -0600 (Tue, 15 Jan 2008) | 2 lines

        Merge queue changes from Bug ASTERISK-211

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=2415


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development