Asterisk
  1. Asterisk
  2. ASTERISK-2461

[patch] Holdtime incorrectly announced as '1 minutes' when holdtime less than 2 minutes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Applications/app_queue
    • Labels:
      None
    • Mantis ID:
      2500
    • Regression:
      No

      Description

      Original implementation of holdtime announcement was based on the notion of not announcing holdtimes smaller than two minutes. To do otherwise would require another recording, etc.

      Someone added ability to announce second estimation as well as minutes. I am not sure this is a great idea, since the seconds estimation is probably not statistically sound.

      Anyway, this fixes the holdtime announcement so it won't say "holdtime is one minutes". It just won't say holdtime unless it rounds to 2 minutes or more.

      Another option for this would be to have Allison record a soundfile "The estimated holdtime is currently one minute or less."

                • ADDITIONAL INFORMATION ******

      Yes, I have a disclaimer on file.

        Activity

        rwjblue added a comment -

        Seems to work correctly for me. Tested by forcing the avg hold time up and listening. Didn't try with tons of calls, but seems to be OK. I believe that there is a reference in queues.conf saying that the avg holdtime will be said if it is greater than 60 seconds. Shouldn't we also update that file so that the example comments are correct? Just a suggestion.

        Mark Spencer added a comment -

        Fixed in CVS to say "less than two minutes" instead of "one minutes"

        Russell Bryant added a comment -

        example config updated

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 3834

        U trunk/apps/app_queue.c
        U trunk/res/res_agi.c
        A trunk/sounds/queue-less-than.gsm
        U trunk/sounds.txt

        ------------------------------------------------------------------------
        r3834 | markster | 2008-01-15 15:08:09 -0600 (Tue, 15 Jan 2008) | 2 lines

        Make holdtime announcement say "less than 2 minutes" instead of "1 minutes" (bug ASTERISK-2461)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=3834


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development