Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      2518
    • Regression:
      No

      Description

      In trying to hook up a G3R switch to the asterisk box, I've discovered that some of the timer (T200, T306, etc.) settings are different by default. Right now those timers are hard-coded in the header files, but should be configurable on a span-by-span basis.

                • ADDITIONAL INFORMATION ******

      I may be able to put this in if there is enough interest... Still trying to figure out why I can't connect to our G3R.

        Activity

        James Golovich added a comment -

        This would be very nice to have. I'd like to hear from Mark on how he would like this implemented but I suspect we would want to add 2 new functions to libpri:
        pri_set_timer
        pri_get_timer

        and a place to store all the timers in struct pri (some of them already have a place)

        and in the public header file a bunch of #defines mapping specific timers to integers so we can call pri_set_timer(PRI_TIMER_T200, value);

        and then add some #defines for default timer values.

        Oh one last thing, last I looked we still have 3-5 timers that haven't been implemented yet. Good to at least have a place for these for when they get implemented

        James Golovich added a comment -

        This seemed like something fun so I threw together some code in libpri to allow this. A bit more work to do but it should be done shortly

        mschaefe added a comment -

        I'm not terribly familiar with the code. I suspect that you wouldn't want to change the timers during runtime, so I would have added it as an option to pri_new, but that would definitely make that the header to kill all headers. At some point I want to investigate how hard it would be to put some hooks into zaptel because you shouldn't have to bring the entire PBX down to add a T1 port. I want to be able to do some experimentation hooking new devices in, but I still have lab users that are running applications on the switch that I can't afford to be down.

        Mark Spencer added a comment -

        Are we ready to close out this bug since the timers are now configurable?

        James Golovich added a comment -

        Committed to CVS.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development