Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      2838
    • Regression:
      No

      Description

      With this app, you can pick any header from an incoming invite and stuff it into a channel variable. It is a generic way of supporting any header a vendor or service provider may add that you want to use in your dial plan.

                • ADDITIONAL INFORMATION ******

      Disclaimer on file

        Activity

        zoa added a comment -

        im also testing and using this, looks good so far.

        petersv added a comment -

        Khb is correct. For C (but not C++) NULL is of type (void *). All compilers should implement NULL tihs way. The extra cast is not needed.

        For C++ it is the other way around, NULL must be of integral type, not pointer type since void* is not assignable to all pointer types but 0 is. Since Asterisk is C and not C++ this is just trivia.

        Mark Spencer added a comment -

        Added to CVS.... I had to hold my nose, but thanks.

        Russell Bryant added a comment -

        not in 1.0

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 4374

        U trunk/channels/chan_sip.c

        ------------------------------------------------------------------------
        r4374 | markster | 2008-01-15 15:15:30 -0600 (Tue, 15 Jan 2008) | 2 lines

        Add nasty sip get header, too (bug ASTERISK-2789)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=4374


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development