Asterisk
  1. Asterisk
  2. ASTERISK-3396

Manager interface outputs caller id of called, instead of caller one

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      3471
    • Regression:
      No

      Description

      Disclaimer: First time we submit a bug: plz forgive us if something is wrong/missing

      Situation:

      SIP/381 is calling SIP/380.

      Events from manager API

      Event: Newchannel
      Channel: SIP/380-e612
      State: Ringing
      CallerID: 380
      CallerIDName: 381
      Uniqueid: 1107098929.188

      It seems to us that CallerID is wrong, even if CallerIDName is right.

      Tnx!

        Activity

        Tilghman Lesher added a comment -

        The Newchannel event describes an unbridged connection (i.e. where there's only one leg). The Callerid therefore can only describe the one channel that is present. Only when two call legs are bridged will there be another callerid (that of the bridged channel). See the manager Link event. You can then either note the previous manager event describing the callerid of each channel or you can request information on the bridged channel, via "Command: show channel $chan".

        Either way, this is not a bug.

        Mark Spencer added a comment -

        Actually, the callerid name should be empty or (as I've added just now) it can be pulled from dialplan hints.

        Mark Spencer added a comment -

        Fixed in CVS head

        Russell Bryant added a comment -

        not an issue in 1.0

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 4938

        U trunk/apps/app_dial.c
        U trunk/configs/extensions.conf.sample
        U trunk/doc/README.variables
        U trunk/include/asterisk/pbx.h
        U trunk/manager.c
        U trunk/pbx.c

        ------------------------------------------------------------------------
        r4938 | markster | 2008-01-15 15:23:53 -0600 (Tue, 15 Jan 2008) | 2 lines

        Allow hints to have names (bug ASTERISK-3396)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=4938


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development