Asterisk
  1. Asterisk
  2. ASTERISK-3415

include calleridname when app_dial changes callerid

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Applications/app_dial
    • Labels:
      None
    • Mantis ID:
      3490
    • Regression:
      No

      Description

      As of Asterisk 1.0.5(or 1.0.4, not sure) all calls that are placed through app_dial(Zap, IAX2, SIP) have the callerID that was set when the call was placed deleted and replaced only with the exten/macroexten.

      I have read the bug that created this change http://bugs.digium.com/bug_view_page.php?bug_id=0002489 and am wondering if it would be possible, and not conflict with any of the reasons that this change was made, to include the original callerid or calleridname that was set when the call was initiated as the calleridname of the new callerid.

      This would greatly help send custom information along with the call including who it is you are calling as well as allow for unique tagging of call instances which is still not possible any other way in asterisk.

      Also, a question, any reason why calleridname as a seperate manager output line was stopped in the last release?

        Activity

        Russell Bryant added a comment -

        re-opening so nicolasg can add a patch

        Russell Bryant added a comment -

        Ok, so, I decided to just revert the original patch from bug ASTERISK-2451 to preserve the original behavior in 1.0 without having to add an option. The original bug that was intended to fix will just remain one of the "known issues" in 1.0.

        Sorry for any inconvenience it caused you guys!

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 4954

        U trunk/apps/app_dial.c

        ------------------------------------------------------------------------
        r4954 | markster | 2008-01-15 15:24:08 -0600 (Tue, 15 Jan 2008) | 2 lines

        Add new 'p' flag to Dial for preserve callerid (bug ASTERISK-3415)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=4954

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 4955

        U trunk/apps/app_dial.c

        ------------------------------------------------------------------------
        r4955 | markster | 2008-01-15 15:24:09 -0600 (Tue, 15 Jan 2008) | 2 lines

        REname 'p' option to 'o' (bug ASTERISK-3415)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=4955

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 4994

        U branches/v1-0/apps/app_dial.c

        ------------------------------------------------------------------------
        r4994 | russell | 2008-01-15 15:24:51 -0600 (Tue, 15 Jan 2008) | 2 lines

        preserve original callerid functionality for 1.0 (bug ASTERISK-3415)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=4994


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development