Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/Configuration
    • Labels:
      None
    • Mantis ID:
      3558
    • Regression:
      No

      Description

      /var/run/asterisk.ctl is the socket to which asterisk -x writes to. This socket is created at every (re)start.

      This patch adds several configuration features to asterisk.conf:

      [files]
      astctlpermissions = 0660
      astctlowner = root
      astctlgroup = apache
      astctl => asterisk.ctl

      First it defines the socket name, which is at this moment hardcoded.
      It defines the owner and group of the socket, to which the socket is chown(2)ed.
      And it changes the permissions on the socket, so that other processes which are not run as root can use the socket.

        Activity

        Edwin Groothuis added a comment -

        The patch-Makefile adds the (commented out) configuration lines to /etc/asterisk/asterisk.conf with a warning above.

        The patch-asterisk.c adds the features to the reading of the configuration and creation of the socket.

        Edwin Groothuis added a comment -

        patch-asterisk.c-1.0.5 is for the 1.0.5 version of the asterisk distribution.

        Mark Spencer added a comment -

        But asterisk already supports changing /var/run. Is it really worthwhile to change the name of the file itself as opposed to just putting them in subdirectories?

        Edwin Groothuis added a comment -

        It is not only the name of the file, but also the ownership and the permissions.
        The possibility to change the name of the file is just to make the picture complete.

        Olle Johansson added a comment -

        Is this patch disclaimed?

        I think the ownership and permissions are important additions.

        Edwin Groothuis added a comment -

        oej: disclaimer has been sent earlier in 2004 (can't recall the date). Thanks for your support

        Mark Spencer added a comment -

        Added to CVS, thanks!

        Russell Bryant added a comment -

        not included in 1.0 since it is a new feature

        Thanks!


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development