Asterisk
  1. Asterisk
  2. ASTERISK-3784

[Patch] [post 1.2] answer and hungup on polarity switch Fix (works in SPAIN)

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/chan_zap
    • Labels:
      None
    • Mantis ID:
      3874
    • Regression:
      No

      Description

      In spain we don't have call progress nor disconnect supervision (fxs_ks doesn't detect anything).
      However, some situations are signalled with polarity switchs.
      There is information from the TelCo here http://www.telefonica.es/interfaces/doc_pdf/ITE-CA-001-V04.pdf (page 23, 5.4.3).

      There is a problem with the current implementation, in that it doesn't detect the remote party hungup. While in conversation, a polarity switch means that.

      Also, there was a problem with p->polaritydelaytv not being updated when a call was answered, which caused that a further polarity switch would be always ignored, when checking for polarityonanswerdelay.

      This patch works for me, but more feedback is needed, beacuse it could break other things.

      julianjm at gmail dot com

                • ADDITIONAL INFORMATION ******

      This is my current zapata.conf, regarding this issue:

      [channels]
      signalling=fxs_ks
      context=from-pstn
      busydetect=no
      answeronpolarityswitch=yes ;;;
      hanguponpolarityswitch=yes ;;;
      callprogress=no
      progzone=es
      channel => 4

        Activity

        Josef Seger added a comment -

        I will test the patch in 6229 during the weekend. I'll be back with comments.

        Josef Seger added a comment -

        I have tested the patch in 6229 since Sunday. It seems to work without issues.

        Josef Seger added a comment -

        I have tested the patch in 6229 since Sunday. It seems to work without issues.

        mattf added a comment -

        Ok, cool. I'm closing this then. I committed the fix for 6229 already.

        mattf added a comment -

        fixed w/ patch in 6229


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development