Asterisk
  1. Asterisk
  2. ASTERISK-4638

[patch] add a feature_timer member to bridge_config

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Resources/res_features
    • Labels:
      None
    • Mantis ID:
      4760
    • Regression:
      No

      Description

      Currently the feature engine hijacks the timer from the call limit feature thus cancelling any timed calls. This patch adds a timer (a long int) specifically for features so they can co-exist properly.

                • ADDITIONAL INFORMATION ******

      Disclaimer on File
      anthmct@yahoo.com
      http://www.pbxfreeware.org

        Activity

        Anthony Minessale added a comment -

        clive, apply timelimitdebug.diff and you can see the state of the timer on the cli during the call. This will tell you if dtmf is affecting the call or not with and without the patch.

        Anthony Minessale added a comment -

        wait there's more needs this too or the timer resets when you have any featre flags installed.

        Anthony Minessale added a comment -

        it looks like rev2 is committed into CVS already but it's not resolved but that's ok cos I had to patch it even more and move the start time into the config obj so it's not reset whenever you exit ast_channel_bridge.

        Mark Spencer added a comment -

        Fixed in CVS head (with minor changes), thanks!

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 6268

        U trunk/channel.c
        U trunk/include/asterisk/channel.h
        U trunk/res/res_features.c

        ------------------------------------------------------------------------
        r6268 | markster | 2008-01-15 15:43:30 -0600 (Tue, 15 Jan 2008) | 2 lines

        Fix timestamp issue with features (bug ASTERISK-4638 with mods)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=6268


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development