Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/NewFeature
    • Labels:
      None
    • SVN Revision Number:
      60212
    • Mantis ID:
      5014
    • Regression:
      No

      Description

      this is more or less my current SIP playground, that i want to share with others.
      maybe some of these ideas could be the starting point for properly implemented features within asterisk. please feel free to use this for inspiration.
      some of the features are highly experimental. so be warned!

      1. backtrace.txt
        8 kB
      2. crash-1
        26 kB
      3. deadlock-festr-2
        119 kB
      4. draft-anil-sipping-bla-02.txt
        90 kB
      5. experimental-20050927.patch.txt
        21 kB
      6. experimental-20051012.patch.txt
        19 kB
      7. experimental-pickup-20051014.patch.txt
        19 kB
      8. experimental-pickup-20051117-1_2.patch.txt
        19 kB
      9. issue5014-1.4.diff
        9 kB
        Sean Bright
      10. issue5014-trunk.diff
        9 kB
        Sean Bright
      11. pf_intercept_monitored.patch
        15 kB
        Sylvain Boily
      12. pickup-locks-2005-10-01.patch.txt
        1 kB
      13. pickup-locks-2005-10-02.patch.txt
        2 kB
      14. pickup-locks-2005-10-11.patch.txt
        2 kB
      15. pickup-mgernoth-2006-07-28.patch.txt
        13 kB
      16. pickup-mgernoth-2006-10-03.patch
        12 kB
      17. pkempgen-pickup-60212.patch
        22 kB
      18. simple-pickup-2007-03-31.patch
        2 kB
      19. sip.snom
        2 kB
        Gregory Hinton Nietsky
      20. sip.snom.pu
        2 kB
        Gregory Hinton Nietsky
      21. siptrace-notify.txt
        14 kB
      22. snom-trunk-20060128.gz
        9 kB

        Activity

        pkempgen added a comment -

        > Note that the Caller ID information will not be available on the SNOM.
        > There is currently no reliable way of getting this information. I
        > reiterate the phrase "no reliable" because I have seen the other patches
        > attached to this issue that pass Caller ID name and number along with the
        > extension state change events. While this works for a lot of cases, in
        > others it won't

        What was wrong with it?

        Sean Bright added a comment -

        Nothing was wrong with it, but here is a (somewhat contrived) example of one of the issues:

        SNOM: Monitoring extension 100
        Call A: Call from "Joe <1>" to 100
        Call B: Call from "Jane <2>" to 100

        Call A calls 100, "Joe <1>" is sent to the SNOM via NOTIFY (100 is now 'ringing).
        Call B calls 100, "Jane <2>" is sent to the SNOM via NOTIFY (100 is still ringing).

        Now, we have two separate calls with distinct CID data. Which one is "right?" Which do we display on the SNOM? The whole point is that the CID information is not predictive.

        pkempgen added a comment -

        I see. Not predictive unless either call waiting was disabled on 100 or
        Pickup() was predictive to always pickup the latest call.

        btw: Your |B| mark causes the teyt to be bold (improper HTML-escaping in
        Mantis).

        Sean Bright added a comment -

        Correct. The way Pickup (with an exten/context argument) works now is it will just pickup the first channel it finds that matches the criteria.

        (And I fixed my previous note, sorry about yelling )

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 145226

        U trunk/CHANGES
        U trunk/channels/chan_sip.c

        ------------------------------------------------------------------------
        r145226 | russell | 2008-09-30 16:22:56 -0500 (Tue, 30 Sep 2008) | 16 lines

        Add support for call pickup on Snom phones. Asterisk now includes a magic
        call-id in the dialog-info event package used with extension state subscriptions
        on Snom phones. Then, when the phone sends an INVITE with Replaces for the
        special callid, Asterisk will perform a pickup on the extension that was
        subscribed to.

        The original code on this issue was submitted by xylome. However, contributions
        have been made by (at least) mgernoth and pkempgen. The final patch was written
        by seanbright, and includes the necessary logic to allow this work in a
        technology independent way.

        (closes issue ASTERISK-4887)
        Reported by: xylome
        Patches:
        issue5014-trunk.diff uploaded by seanbright (license 71)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=145226


          Dates

          • Created:
            Updated:
            Resolved:

            Development