Asterisk
  1. Asterisk
  2. ASTERISK-5193

retrans_pkt: Maximum retries exceeded on transmission XXXX for seqno 102 (Critical Response)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      5336
    • Regression:
      No

      Description

      I keep seeing these messages on Asterisk console. This happens when a Cisco 79X0 (SIP 7.5) calls another Cisco 79X0 and hangs up. Turning SIP Debug ON reveals Asterisk trying to send "487 Request Terminated" to Cisco phone and eventually gives up producing above message.

                • ADDITIONAL INFORMATION ******

      attaching sip debug with verbose/debug set to 4.

        Activity

        Serge Vecher added a comment -

        Apparently, using eyebeam to call Cisco IP Phone does not cause this problem. Please help! I think all the excessive traffic causes the Cisco IP Phones to hangup with "XML Parse error" messages displayed on phone's screen. Only rebooting the phone helps

        Joshua Colp added a comment -

        I don't think this is a problem with Asterisk - essentially what happens when you cancel a call is this:

        1. Phone sends CANCEL
        2. We send 487 Request Terminated
        3. We send 200 OK
        4. Phone sends ACK to acknowledge the above messages.

        Your Cisco phone is not sending an ACK back, so Asterisk continues to send the 487 Request Terminated because it knows no better. Eyebeam however does reply with an ACK and thus Asterisk doesn't resend the 487 over and over.

        Michael Jerris added a comment -

        This is a problem with sip non-compliance by the cisco phone as josh said, specifically, rfc3261, section 17.1.1 requries an ACK to the 487. If we do not get ACK'd, we should resend.

        Serge Vecher added a comment -

        Just for the record, the problem was indeed with Cisco phones. Downgrading to SIP firmware 7.4 eliminated the issue. Joshnet and MikeJ – thanks for helping to track this one down. Please close the bug.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development