Asterisk
  1. Asterisk
  2. ASTERISK-553

Public IP * forgets to check on registered dynamic IP *: Unreachable!

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      558
    • Regression:
      No

      Description

      SETUP
      server A: static IP (public)
      server B: dynamic IP (cable modem)
      none of the machines are behind NAT
      server B registers with server A as peer

      PROBLEM
      The cable modem link of server B regularly drops below 2000 ms but comes back up quickly again - fine so far. However, with "iax2 show peers" on server A I permanently see a status of UNKOWN for server B. A "reload" on server A fixes the problem and I see a status of "OK (76) ms", and now I can place calls again.
      As a workaround I could schedule a "reload" on server A once per hour, but I don't think this is the way it should be.

        Activity

        philipp2 added a comment -
        Brian West added a comment -

        no in some cases I see restart do stuff that a reload won't can you see if one or the other is true in this case?

        philipp2 added a comment -

        Neither restart nor reload helps, at least not on the long run. I now turned to register the servers using SIP as fallback if IAX fails, and now most if not all connections use SIP (which means that "SIP is better than IAX" - hehe!). First I tried the regular "reload", but you read aobut the "reload" bug as well...

        Brian West added a comment -

        NO this is a config issue

        host=dynamic
        defaultip=111.222.333.444

        Don't use those together.. use one or the other.

        Brian West added a comment -

        ASTERISK-667 fixed this or so it should have.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development