Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Resources/NewFeature
    • Labels:
      None
    • SVN Revision Number:
      48570
    • Mantis ID:
      5768
    • Regression:
      No

      Description

      Here is a ldap realtime driver.
      res_config_ldap.c: code
      res_ldap.conf.sample: res_ldap.conf sample
      asterisk.ldap-schema: example of ldap schema
      ldap-patch.diff: Makefile patch

                • ADDITIONAL INFORMATION ******

      The latest code is located here http://svn.digium.com/view/asterisk/team/group/res_config_ldap

      1. asterisk.schema
        10 kB
      2. asterisk-v2.schema
        16 kB
      3. asterisk-v3.1.1.ldif
        19 kB
        Gavin Henry
      4. asterisk-v3.1.1.schema
        18 kB
        Gavin Henry
      5. asterisk-v3.1.2.ldif
        19 kB
        Gavin Henry
      6. asterisk-v3.1.2.schema
        19 kB
        Gavin Henry
      7. asterisk-v3.1.4.ldif
        19 kB
        Gavin Henry
      8. asterisk-v3.1.4.schema
        19 kB
        Gavin Henry
      9. asterisk-v3.1.schema
        18 kB
        Gavin Henry
      10. asterisk-v3.schema
        18 kB
        Gavin Henry
      11. debug1.txt
        3 kB
      12. patch_res_config_ldap.diff
        3 kB
      13. res_config_ldap.c
        52 kB
      14. res_config_ldap.c.0.9
        53 kB
      15. res_config_ldap.c.patch
        9 kB
      16. res_config_ldap.c-svn-diff-50465
        10 kB
      17. res_config_ldap.patch
        51 kB
      18. res_config_ldap.tgz
        10 kB
      19. res_config_ldap-formatting.1.patch
        19 kB
      20. res_config_ldap-v0.7.tar.gz
        10 kB
      21. res_ldap.conf.sample
        4 kB
        Gavin Henry
      22. res_ldap.conf.sample.patch
        0.5 kB

        Activity

        Gavin Henry added a comment -

        Yes, it works using the schema I did above.

        Tilghman Lesher added a comment -

        Okay, so for committing this, I need to merge the branch and add asterisk-v3.1.4.ldif and asterisk-v3.1.4.schema to the contrib directory. Is there anything that I'm missing here?

        Gavin Henry added a comment -

        The docs; readme and sample .conf

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 99696

        _U trunk/
        U trunk/CHANGES
        U trunk/build_tools/menuselect-deps.in
        A trunk/configs/res_ldap.conf.sample
        U trunk/configure
        U trunk/configure.ac
        A trunk/contrib/scripts/asterisk.ldap-schema
        A trunk/contrib/scripts/asterisk.ldif
        A trunk/doc/ldap.txt
        U trunk/include/asterisk/autoconfig.h.in
        U trunk/makeopts.in
        A trunk/res/res_config_ldap.c

        ------------------------------------------------------------------------
        r99696 | tilghman | 2008-01-22 16:30:42 -0600 (Tue, 22 Jan 2008) | 10 lines

        Add res_config_ldap for realtime LDAP engine.
        (closes issue ASTERISK-5620)
        Reported by: mguesdon
        Patches:
        res_config_ldap-v0.7.tar.gz uploaded by mguesdon (license 121)
        res_ldap.conf.sample uploaded by suretec (license 70)
        asterisk-v3.1.4.ldif uploaded by suretec (license 70)
        asterisk-v3.1.4.schema uploaded by suretec (license 70)
        Tested by: oej, mguesdon, suretec, cthorner

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=99696

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 99859

        _U team/murf/bug11210/
        U team/murf/bug11210/CHANGES
        U team/murf/bug11210/apps/app_voicemail.c
        U team/murf/bug11210/build_tools/menuselect-deps.in
        U team/murf/bug11210/channels/chan_sip.c
        A team/murf/bug11210/configs/cli.conf.sample
        A team/murf/bug11210/configs/res_ldap.conf.sample
        U team/murf/bug11210/configure
        U team/murf/bug11210/configure.ac
        A team/murf/bug11210/contrib/scripts/asterisk.ldap-schema
        A team/murf/bug11210/contrib/scripts/asterisk.ldif
        A team/murf/bug11210/doc/ldap.txt
        U team/murf/bug11210/doc/tex/channelvariables.tex
        U team/murf/bug11210/include/asterisk/autoconfig.h.in
        U team/murf/bug11210/include/asterisk/channel.h
        U team/murf/bug11210/main/acl.c
        U team/murf/bug11210/main/asterisk.c
        U team/murf/bug11210/main/channel.c
        U team/murf/bug11210/makeopts.in
        A team/murf/bug11210/res/res_config_ldap.c
        U team/murf/bug11210/res/res_odbc.c

        ------------------------------------------------------------------------
        r99859 | murf | 2008-01-23 07:20:24 -0600 (Wed, 23 Jan 2008) | 149 lines

        Merged revisions 99642,99644-99647,99653,99696,99700,99719,99758,99776,99778,99818,99839 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/trunk

        ................
        r99642 | russell | 2008-01-22 13:33:16 -0700 (Tue, 22 Jan 2008) | 3 lines

        Change the Asterisk CLI startup commands feature to read commands to run from cli.conf
        after a discussion on the -dev list.

        ................
        r99644 | oej | 2008-01-22 13:35:10 -0700 (Tue, 22 Jan 2008) | 18 lines

        Add a generic function to set the bridged call PVT unique id string
        as a channel variable BRIDGEPVTCALLID

        This is important for call tracing in log files and CDRs, so that
        the SIP callID can be traced along servers.

        The CHANNEL dialplan function won't work here, since the outbound
        channel is gone when we need the Call-ID.

        Other channel drivers may now implement the same function ,
        but this patch only supports chan_sip.so.

        Inspired by (issue ASTERISK-11279)
        Reported by: ctooley

        Patch by oej

        ................
        r99645 | russell | 2008-01-22 13:41:05 -0700 (Tue, 22 Jan 2008) | 2 lines

        Make sure the command is not just present but is also configured to be executed

        ................
        r99646 | tilghman | 2008-01-22 13:42:47 -0700 (Tue, 22 Jan 2008) | 10 lines

        Merged revisions 99643 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r99643 | tilghman | 2008-01-22 14:34:55 -0600 (Tue, 22 Jan 2008) | 2 lines

        Fix the defines for OS X (and Solaris, too)

        ........

        ................
        r99647 | oej | 2008-01-22 13:44:56 -0700 (Tue, 22 Jan 2008) | 2 lines

        Documentation updates for BRIDGEPVTCALLID

        ................
        r99653 | oej | 2008-01-22 14:09:37 -0700 (Tue, 22 Jan 2008) | 12 lines

        Merged revisions 99652 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r99652 | oej | 2008-01-22 21:56:09 +0100 (Tis, 22 Jan 2008) | 4 lines

        Thanks to Russell's education I realize that BUFSIZ has changed since I learned the C language
        over 20 years ago... Resetting chan_sip to the size of BUFSIZ that I expected in my old
        head to avoid too heavy memory allocations on some systems.

        ........

        ................
        r99696 | tilghman | 2008-01-22 15:33:20 -0700 (Tue, 22 Jan 2008) | 10 lines

        Add res_config_ldap for realtime LDAP engine.
        (closes issue ASTERISK-5620)
        Reported by: mguesdon
        Patches:
        res_config_ldap-v0.7.tar.gz uploaded by mguesdon (license 121)
        res_ldap.conf.sample uploaded by suretec (license 70)
        asterisk-v3.1.4.ldif uploaded by suretec (license 70)
        asterisk-v3.1.4.schema uploaded by suretec (license 70)
        Tested by: oej, mguesdon, suretec, cthorner

        ................
        r99700 | tilghman | 2008-01-22 17:10:45 -0700 (Tue, 22 Jan 2008) | 2 lines

        Oops

        ................
        r99719 | tilghman | 2008-01-22 18:06:27 -0700 (Tue, 22 Jan 2008) | 10 lines

        Merged revisions 99718 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r99718 | tilghman | 2008-01-22 18:56:06 -0600 (Tue, 22 Jan 2008) | 2 lines

        Just confirmed that all current platforms need this header file

        ........

        ................
        r99758 | tilghman | 2008-01-22 20:57:31 -0700 (Tue, 22 Jan 2008) | 2 lines

        Coding guidelines cleanup

        ................
        r99776 | tilghman | 2008-01-22 21:25:33 -0700 (Tue, 22 Jan 2008) | 10 lines

        Merged revisions 99775 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r99775 | tilghman | 2008-01-22 22:20:15 -0600 (Tue, 22 Jan 2008) | 2 lines

        Oops, should have checked for a NULL obj, here, too

        ........

        ................
        r99778 | tilghman | 2008-01-22 21:35:04 -0700 (Tue, 22 Jan 2008) | 16 lines

        Merged revisions 99777 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r99777 | tilghman | 2008-01-22 22:31:51 -0600 (Tue, 22 Jan 2008) | 8 lines

        When we reset the password via an external command, we should also reset the
        password stored in the in-memory list, too (otherwise it doesn't really take
        effect).
        (closes issue ASTERISK-11273)
        Reported by: davetroy
        Patches:
        fix_externpass.diff uploaded by davetroy (license 384)

        ........

        ................
        r99818 | tilghman | 2008-01-22 22:29:28 -0700 (Tue, 22 Jan 2008) | 2 lines

        Coding guidelines fixups

        ................
        r99839 | oej | 2008-01-23 03:18:13 -0700 (Wed, 23 Jan 2008) | 3 lines

        • Add a few comments to sip_xmit
        • Make sure that we are aware of a pending INVITE even if we're using TCP

        ................

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=99859


          Dates

          • Created:
            Updated:
            Resolved:

            Development