Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/chan_local
    • Labels:
      None
    • Mantis ID:
      5779
    • Regression:
      No

      Description

      This patch adds a devicestate function to chan local that merely reports whether or not an extension exists. It also adds a metermaid function to parking in res_features:

      chan_local registers as a metermaid, res_features alerts every time a call is parked or unparked (extension appears and disappears in the parkedcalls context).

      Now, if you add a hint that points to local/701@parkedcalls and subscribe to that in SIP, you will immediatelly see when a call is parked on that extension!

        Activity

        mjc added a comment -

        FuriousGeorge,

        If you want something for a production system, apply the metermaid-1.2.7.1.txt patch against 1.2.9.1 (that's what I'm using, very happily). If you want to test/develop/improve, use oej's branch.

        What phone are you using? My Snom 360 LEDs work fine for showing parking slot status (with 1.2.9.1 + metermaid-1.2.7.1.txt). If "show hints" works correctly but your LEDs don't, that suggests a phone configuration or context problem.

        • Mike
        phat sam added a comment -

        After going through all the rej files, and finding no real reason why all were failing, i discovered that the patch that is downloaded from this ticket is infact in DOS format! Needless to say i'm confused why this has come about. However for future reference, and anyone else that wants to try this excellent/necessary feature, convert the file to unix format and everything "just works"(tm). Maybe the patch app is defaulted differently on Gentoo, i dont know.

        philipp2 added a comment -

        metermaid-1.2.7.1 is not working out for me on two systems:

        1. Debian Sarge, plain asterisk 1.2.9.1 seg faults upon launch with patch applied:

        == Parsing '/etc/asterisk/queues.conf': Found
        Segmentation fault (core dumped)
        karl:/usr/src# Ouch ... error while writing audio data: : Broken pipe
        Ouch ... error while writing audio data: : Broken pipe
        Ouch ... error while writing audio data: : Broken pipe
        Ouch ... error while writing audio data: : Broken pipe

        2. Gentoo, bristuffed asterisk 1.2.9.1 doesn't light up the LED on the SNOM 360 (firmware 6.2.2) because "show hints" always gives "idle" for 701 no matter if a caller has been parked or not (the only other patch applied is 5515 for MGCP hint functionality, but that shouldn't interfere).

        In both cases it doesn't make a difference if the patch is "unix'ed" first (dos2unix), or if res_features is explicitely loaded before chan_local in modules.conf.

        Anyway, I am very much looking forward to 1.4, especially as I see that the "post 1.4" tag was removed from this patch, and oej stated that also meetme is covered in SVN, not just parking - thanks oej! Maybe I can set up a SVN test...

        Olle Johansson added a comment -

        This bug report is only about the patches in the branch for svn trunk. Please do not use it to discuss older code or unsupported patches. You are adding irrelevant information.

        Do test the branch where we fix problems and try to get working code. Thanks.

        Olle Johansson added a comment -

        Committed to svn trunk, rev 36055. Thank you all!


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development