Asterisk
  1. Asterisk
  2. ASTERISK-6156

New option n / Disable the conf-onlyperson message

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Mantis ID:
      6316
    • Regression:
      No

      Description

      Hi,

      since we are using MeetMe as a replacement for a phone conference button, we found the message "you are currently the only person in this conference" annoying. We could use q but this would disable all sounds including entry sounds etc.

      I therefore added option "n" to disable conf-onlyperson and conf-waitforleader only. The patch is against SVN 1.2.

                • ADDITIONAL INFORMATION ******

      Disclaimer is signed.

        Activity

        Tilghman Lesher added a comment -

        If you genuinely don't like that message for your installation, why not just shorten that file to 0 length?

        Jan-Peter Koopmann added a comment -

        Because we are using MeetMe for two seperate things:

        1. Common conference room application. In this case the message makes sense and is wanted.

        2. As a replacement for a 3-way conference button on a telephone (which not all phones have or does not work all the time like in our case).

        In the second case while talking to a customer or friend (if using * at home), you suddenly decide to get an additional person to the call, making it a 3-way conference. In these cases I tell the other side that I will try to get the next person in the call. For the other person this should be just like being put to hold, meaning that she/he hears MOH immediatly without any prompts. Nevertheless it might make sense to hear the other sounds.

        In order to achieve both things I needed an additional option.

        Kind regards,
        JP

        Joel Vandal added a comment -

        Why not simply create a directory in /var/lib/asterisk/sounds/meetme2, create empty conf-onlyperson and conf-waitforleader files and in your dialplan do:

        exten => s,1,SetLanguage(meetme2)
        exten => s,2,Meetme...


        Joel

        Jan-Peter Koopmann added a comment -

        Obvious reason: Because I did not think of that.

        However, come to think of it, if you are maintaining a few languages, this is annoying as well. If I set language de by default, I will need de and de-meetme. Then if I set the language according to the callerid, I will even need more directories and copies/links to the language files. I agree it is all pretty simple if you stick to english.

        I prefer a simple option in the application. If you guys don't, no worries, ignore/close the case. I will survive.

        Regards,
        JP

        Olle Johansson added a comment -

        Re-opening on Tony Mountfield's request.

        Tony Mountifield added a comment -

        I'd like to speak in support of this feature, as I was just about to do the same thing myself.

        It's a small change which gives a genuinely useful feature without the kludginess of the alternative approaches that were proposed above.

        Tilghman Lesher added a comment -

        Committed to trunk


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development