Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      652
    • Regression:
      No

      Description

      The PUBLISH-SUBSCRIBE SIP methods allow the function of the status LEDs on SIP phones such as the SNOM 200 to monitor other extensions, etc.

                • ADDITIONAL INFORMATION ******

      Draft source:
      http://www.ietf.org/internet-drafts/draft-ietf-sip-publish-01.txt

        Activity

        Olle Johansson added a comment -

        zoa: Is it possible to catch the whole packet and publish here? I'm a bit curious.

        geertn added a comment -

        oej, you can activate this in your snom.
        In Settings :: SIP :: Stack: Publish Presence -> ON.

        Running latest firmware: snom200-SIP 2.04g

        I attached the PUBLISH packet in publish.txt

        Brian West added a comment -

        We have subscribe now dont we?

        Mark Spencer added a comment -

        We support subscribe/notify but we don't use PUBLISH (actually it makes sense, again, since Asterisk is a PBX and not a Proxy) so I think this is basically finished.

        jamieg added a comment -

        Reminder sent to atacomm

        I landed on this Bug due to falling into the PUBLISH error coming from a SNOM phone. I have had great interest in this issue for Asterisk as I feel its one that keeps it from really competing with the top end of the PBX market.

        Centralised signaling is the way to go. Imagine the capabilites. Imagine if you could monitor all your Friends Personal/Business Lines, like looking an an Instant Messanger..

        In any case, this Bugnote is RESOLVED, but I do not see any real plan or movement here to implement this. The last note is from 4 months ago.

        What and where is this issue going in Asterisk. I have been building up my Asterisk implementation Skills over the last 6 months (Different from development skills I suppose) And a feature of a fully featured receptionist HARD panel is really needed from my experence.

        What are the options, and is this project enhancing the possibilities.

        Thanks Guys.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development