Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Mantis ID:
      6669
    • Regression:
      No

      Description

      While trying to use a huawei softswitch, we notice that they have problems with our SDP package header. What we have done was strip from the header the line "a=SilenceSupp:off" and that way things started working right. To accomplish this we commented this line from channels/chan_sip.c:
      /* ast_build_string(&a_audio_next, &a_audio_left, "a=silenceSupp:off - - - - -\r\n");  */

      This is a patch to solve this "issue", now you can setup on sip.conf on each peer "silencesupp=hide/show" default is 'show'.
      I don't know if this is the right way to solve this problem. Please check it out...

      Thanks

                • ADDITIONAL INFORMATION ******

      Here is the patch....

        Activity

        Olle Johansson added a comment -

        You should propably use a SIP_PAGE2 flag instead. Also make sure it's shown in "sip show peers" etc.

        Russell Bryant added a comment -

        I really don't think we should have to introduce extra options because of other broken implementations. It seems like this bug report would be more appropriately filed with Huawei.

        Olle Johansson added a comment -

        According to e-mails in asterisk-dev, there are more broken implementations out there... I am very hesitant about this too.

        Eliel Sardanons added a comment -

        New patch using SIP_PAGE2 and showing on sip show peers and the manager the status.

        Eliel Sardanons added a comment -

        I don't know if it's important to show the status on "sip show peers", or on the manager... This is a trivial config parameter and doesn't affect other connections than the bogus ones... (Just to continue with a clean CLI output)

        Olle Johansson added a comment -

        With the patch in ASTERISK-5230 this won't be a problem anymore, so I prefer to go that route. It does require a zaptel timer, but actually does the proper thing. Just removing this line without being able to handle incoming silence suppression is asking for other problems.

        Will close this bug report, but leave it in archive for people that needs it to communicate with broken devices.

        Eliel Sardanons added a comment -

        Ok!, so, you will apply part/all the patch from ASTERISK-5230? or you will leave every thing like now.

        Olle Johansson added a comment -

        We will have to test 5374 a bit more, so at this point nothing goes into svn. I think this patch solves your problem for now, even though it won't be part of Asterisk.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development