Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • SVN Revision Number:
      31320
    • Mantis ID:
      7261
    • Regression:
      No

      Description

      Hello,

      I am using asterisk on linux in France.

      I have a message in permance :
      WARNING[30888]: chan_sip.c:5206 determine_firstline_parts: Bad request protocol Packet

      When i set debug :
      <-- SIP read from xxx:5060:
      Cirpack KeepAlive Packet
      Jun 1 15:00:59 WARNING[30888]: chan_sip.c:5206 determine_firstline_parts: Bad request protocol Packet
      — (1 headers 0 lines)---

      i don't known if it is a bug but this message is every 2 second and is fulling my logs.

      Excuse for my english i'm french.

        Activity

        Olle Johansson added a comment -

        It is a bad request packet, so the error message is correct. What is the problem you are reporting here?

        Olle Johansson added a comment -

        Turn off keep alives from the server.

        micled added a comment -

        I can not turn off keep alives from the server because the server is a FAI (Internet Provider) and i am a client of this server.

        Can I turn off this error ?

        I think that the server use another SIP server. Or this other send keep alive packet that asterisk don't known. It is possible to add an option to asterisk to understant this packet ?

        Thank

        Olle Johansson added a comment -

        Well, we have as a policy not to fix problems with other UAs that are broken and not follow the specs. This is clearly such a case. We're just logging these errors. What you can do is go into the source code and remove that warning, recompile, reinstall.

        Jeffrey C. Ollie added a comment -

        If you are running Linux and have a relatively recent kernel you can do something like this:

        iptables -A INPUT -p udp -m udp --dport 5060 -m string --string "Cirpack KeepAlive Packet" -j DROP

        Olle Johansson added a comment -

        Ok, we suggested several ways to solve the issue. Again, since I don't see this as a bug in Asterisk, we will not act on this repot. Thanks for reporting!


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development