Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: None
    • Labels:
      None
    • Mantis ID:
      759
    • Regression:
      No

      Description

      This is a new version of the SIP channel. No major rewrite, but a lot of small changes in one package. Also, I've incorporated a number of patches from bugs.digium.com.

      • THIS IS NOT A FORK * I disclaim the rights to Digium as usual.

      I just wanted to test a lot of things at the same time, so I added some stuff I needed into a different version, so I could roll back to the standard chan_sip if things did not work.

      Please test this and report any problems here. I'll hang on and maintain this for a while until we agree it is production ready.

      • Add chan_sip2 to the channels/Makefile
      • Rename the file downloaded to chan_sip2.c
      • make / make install
      • Change your modules.conf
        Add "noload=chan_sip.so" if you want to run chan_sip2
      • Restart asterisk
          • THIS IS NOT READY FOR PRODUCTION ***

      Test and report here - positive and negative reports.

                • ADDITIONAL INFORMATION ******

      Read the source file for additional information. Things I'm working on are

      • Template support for easier configuration of peers/users
      • Outbound proxy support
      • Additional CLI commands
      • Statistics (in the long run stuff for SNMP maybe)
      • More RFC compliant functionality
      1. 0000759-chan_sip2A5.c
        356 kB
      2. 0000759-chan_sip2A6.c
        355 kB
      3. 0000759-chan_sip2A6-mysql.v1.2.c.diff
        19 kB
      4. 0000759-chan_sip2B.c
        365 kB
      5. 0000759-chan_sip2C.c
        368 kB
      6. 0000759-chan_sip2E.c
        374 kB

        Activity

        Peter Whisker added a comment -

        Olle

        (Feature request!)
        Would it be possible to allow the rest of the [global] parameters to be over-rideable in the SIP peer sections in much the same way as the allow= codec parameters?

        Specifically I need to be able to have a different "externip=" for different peers (as I have multiple NICs). The way it is now, I can register with either one of two of my peers but not both at the same time.

        Thanks
        Peter

        Olle Johansson added a comment -

        Feature requests and support issues is best handled via e-mail or on the IRC - find me!

        Peter: I need to find out what you really want do do, please find me on e-mail or IRC. THank you!

        Clod Patry added a comment -

        Any development in here , oej, since 2 weeks?

        /Housekeeping

        Olle Johansson added a comment -

        Junky, this is not a bug report, it's experimental features, new development. I've been busy fixing real bugs in CVS for a while, but I'll be back updating chan_sip2 soon.

        Olle Johansson added a comment -

        Closing this due to lack of time. Will re-open when I've updated chan_sip2 to current cvs, which will not happen soon.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development