Asterisk
  1. Asterisk
  2. ASTERISK-7631

[patch][post 1.4] Patch to make Background() return a status code in the same way Playback() does.

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      7835
    • Regression:
      No

      Description

      Firstly, I'm not a programmer, so please excuse sloppy coding or misunderstandings, but if somebody could run with this I'd be a happy bunny!

      The Playback() application returns $

      {PLAYBACKSTATUS}

      (either "FAILED" or "SUCCESS"), but the Background() core feature does not.

      Attached is a diff against pbx.c which implements the return of $

      {BACKGROUNDSTATUS}

      (either "FAILED" or "SUCCESS") in the same way Playback() does.

      I've tested it insofar as I can on a production machine and it works for me. Is there any way this can be implemented in Asterisk going forwards?

        Activity

        Serge Vecher added a comment -

        1) looks like you've done your patch backwards
        2) since this is a new feature, it needs to be against trunk, not 1.2.x release.

        Thanks.

        Nick Barnes added a comment -

        1) Doh. Told you I wasn't a programmer. Diff the right way round uploaded.
        2) OK. I'll see what I can do.

        Serge Vecher added a comment -

        3) also, please fax a disclaimer in to Digium. See bottom of this page http://bugs.digium.com/main_page.php

        Nick Barnes added a comment -

        3) Done.

        Jason Parker added a comment -

        Similar patch committed to svn trunk in revision 43814.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development