Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • SVN Revision Number:
      47985
    • Mantis ID:
      8413
    • Regression:
      No

      Description

      I think that Asterisk doesn't have "normal" transfer. There atxfer and blindxfer, but you can't use them both at once. E.g. If transferer hangup during atxfer - transfer will fail, it won't work as blind transfer.

      This patch alter standard behaviour of atxfer. If Transferer hangup during transfer atxfer will work as traditional transfer (like transfer on Panasonic, NEC and other hardware PBXes).

      If third party didn't respond to a transferee, atxfer will initiate callback to a transferer.

        Activity

        David Svanlund added a comment -

        Great! I'll try to test the new patch tomorrow.

        David Svanlund added a comment -

        The new functionality seems to be working as expected.

        Sergey Tamkovich added a comment -

        svanlund, thanks for testing!
        any more volunteers?

        Russell Bryant added a comment -

        I have created a branch for this code to play with while I test and look it over.

        svn co http://svn.digium.com/svn/asterisk/team/russell/issue_8413

        Russell Bryant added a comment -

        This patch has been merged into trunk in revision 62593. Thanks!


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development