Asterisk
  1. Asterisk
  2. ASTERISK-8344

[patch] Limit on simultaneous calls for queue members

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Applications/General
    • Labels:
      None
    • Mantis ID:
      8580
    • Regression:
      No

      Description

      The queue application doesn't allow limits on simultaneous calls for queue members. Some workarounds like call-limit in sip.conf cause many other problems (for example, calls can't be transfered if call-limit is 1). We (at Proformatique) have written a patch for app_queue which allows placing such a limit. queues.conf can then be configured as this :

      member = SIP/100[,penalty[,call-limit]]

      If call-limit isn't specified, it is 0. A call-limit of 0 means no limit. Thus, it shouldn't break any configuration (at least in the static conf file, I haven't tested RealTime configurations).

        Activity

        Sylvain Boily added a comment -

        For people who want to use this patch on latest asterisk 1.2.24, i have upload a new version. (pf_queue_call_limit.patch)

        Richard Braun added a comment -

        A patch for trunk has just been uploaded. Reviews are welcome.

        Ronald Chan added a comment -

        Any news here ? thanks

        Tilghman Lesher added a comment -

        1. Please don't add credits to source files. If you want a credit, add it to the CREDITS file in the root directory.

        2. When adding new options to dialplan apps, please add them at the END of the argument list. Otherwise, you break backwards compatibility. (APIs are different, and rearrangement of those options is fine.)

        3. You are recycling the pausing. It's clear that you're not using that, but queue members who are using that will be very confused if they pause themselves during a call (to take a bathroom break for instance) and are immediately unpaused when the call ends. Please consider that a bug that needs to be fixed (i.e. you should only unpause a member, if their pausing was caused by the call-limit).

        4. Again, messing with string order in the astdb breaks upgrades. Always add new options to the end.

        5. From a usability perspective, "call-limit" is difficult to type. Please consider renaming the CLI keyword "limit".

        Tilghman Lesher added a comment -

        No response from reporter. Reopen if/when you can make the requested changes.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development