Asterisk
  1. Asterisk
  2. ASTERISK-8668

[patch] chan_cellphone - use mobile phones with Bluetooth as FXO devices in *

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/General
    • Labels:
      None
    • SVN Revision Number:
      56683
    • Mantis ID:
      8919
    • Regression:
      No

      Description

      Asterisk Channel Driver to allow Bluetooth Cell/Mobile Phones to be used as FXO devices.

      Features :-

      Multiple cell phones can be connected.
      Asterisk automatically connects to each cell phone when it comes in range.
      CLI Command to discover bluetooth phones.
      CLI Command to show status of connected phones.
      Inbound calls to the cell phones are handled by Asterisk, just like inbound calls on a Zap channel.
      CLI passed through on inbound calls.
      Dial outbound on a cell phone using Dial(CELL/device/nnnnnnn) in the dialplan.
      Application CellStatus can be used in the dialplan to see if a cell phone is connected.
      Supports devicestate for dialplan hinting.
      Calls can be placed / taken from the cellphone or from the Asterisk dialplan.
      Inbound and Outbound SMS Messaging from the Dialplan.

      See doc/cellphone.txt for configuration.

      1. bluetooth_dongles_lsusb_onewayaudio.txt
        29 kB
      2. cellphone_dtmf.log
        0.1 kB
      3. cellphone.txt
        8 kB
      4. cellphone-corrupt-fix.patch
        1 kB
      5. chan_cellphone.debug
        14 kB
      6. chan_cellphone.patch
        46 kB
      7. chan_cellphone-1.4.1-17.patch.gz
        40 kB
      8. chan_cellphone-14.patch
        54 kB
      9. chan_cellphone-14-1.4.1.patch.gz
        39 kB
      10. chan_cellphone-15.patch
        59 kB
      11. chan_cellphone-16.patch
        60 kB
      12. chan_cellphone-17.patch
        60 kB
      13. chan_cellphone-18.patch
        60 kB
      14. chan_cellphone-19.patch
        61 kB
      15. chan_cellphone-19-1.4.2.patch.gz
        41 kB
      16. chan_cellphone-20.patch
        61 kB
      17. chan_cellphone-21.patch
        63 kB
      18. chan_cellphone-22.patch
        64 kB
      19. chan_cellphone-22-1.4.4.patch.gz
        66 kB
      20. chan_cellphone-5-ericsson.patch
        48 kB
      21. chan_cellphone-debug-free-invalid-pointer.txt
        8 kB
      22. chan_cellphone-debug-free-invalid-pointer-complete.txt
        64 kB
      23. chan_cellphone-debug-segfault
        4 kB
      24. hcidump0.txt.gz
        55 kB
      25. K750i_segmentation_error.txt
        8 kB
      26. malwcal-a701-log.txt
        21 kB
      27. malwcal-nokia-6233.log
        2 kB

        Activity

        jabroni added a comment -

        Was wondering if there will be a backport of this drivers for the Asterisk 1.2 branch, since I guess there are people wanting to try out this channel but cant since it would require a 1.4 upgrade, and that would implicate some compatibility changes on current PBX deploys (as some of us uses freepbx, and the current release doesnt support 1.4 yet). I tried a binary posted on another page (he just changed some headers off this drivers in order to make it compile for 1.2) but I couldnt get it to work. I was just wanted to know if there is any 1.2 support planned on the roadmap of this great channel driver.

        Alex Murray added a comment -

        I am having the previosly mentioned problem of one-way audio for INCOMING calls - outgoing calls from my SIP phone work fine with two-way audio, but with incoming calls I only get audio from the SIP phone out to the caller, and I hear nothing on the SIP phone itself.

        Attached is a debug log - if anyone could give me some advice that'd be great.

        I am running Ubuntu Feisty, with Asterisk 1.4.4, cellphone-22 and am using a DLink DBT-120 Usb bluetooth dongle.

        I have been testing with both a Nokia 6230 and a Sony Ericcson k700i and both have this problem.

        Alex Murray added a comment -

        Looks like the attachment didn't work - trying again...

        Also, I would love to see support for multiple BT adapters, as I plan to run with atleast 20 cellphones for the one asterisk box, and so will obviously need to use multiple adapters.
        Cheers

        Jason Parker added a comment -

        dbowerman, the reason this has to go into asterisk-addons, is due to libbluetooth being GPL. The file asterisk/branches/1.4/doc/mysql.txt explains the reasoning behind this (it's for the mysql client libraries specifically, but it applies to all GPL libraries that we link against).

        As for the disclaimers, the patch from oys_ has been removed (per dbowerman), the patch from jhansen has been removed/re-written by me (it's now done the same way that SIP/IAX2 do it), and after re-reading all of the comments here, I found that binsa already has a disclaimer on file with Digium.

        I've renamed the channel driver to chan_mobile - as that seems to make the most sense now. That means that anybody currently using this patch is going to have to do a few things. 1) The config filename must be changed to mobile.conf from cellphone.conf. 2) Before installing from asterisk-addons, you will need to remove /usr/lib/asterisk/modules/chan_cellphone.so 3) CLI/config syntax changes - anywhere you used CELL, you would now use Mobile - ie; Dial(Mobile/fred) instead of Dial(CELL/fred) or "mobile search" instead of "cell search". 4) I can't think of anymore - but I'm sure there are some.

        I'm going to attempt to commit this to asterisk-addons trunk tonight or more likely tomorrow. Once that's done, I'm going to close this bug, and ask that all issues be posted to new bug reports, so that they can be tracked. Per the bug guidelines, please do not open reports for configuration help or similar - dbowerman spent time on the documentation - please read it thoroughly (doc/chan_mobile.txt).

        Jason Parker added a comment -

        Added to svn trunk of asterisk-addons in revision 384.

        Thanks to David Bowerman for his great work with this.

        Show
        Jason Parker added a comment - Added to svn trunk of asterisk-addons in revision 384. Thanks to David Bowerman for his great work with this.