Asterisk
  1. Asterisk
  2. ASTERISK-9028

segfault after a while of operation (maybe a month)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Channels/chan_h323
    • Labels:
      None
    • Mantis ID:
      9299
    • Regression:
      No

      Description

      Subj.
      Asterisk 1.4.1

                • ADDITIONAL INFORMATION ******

      (gdb) bt full
      #0 0xb6e791b0 in strcmp () from /lib/tls/libc.so.6
      No symbol table info available.
      #1 0xb554864d in find_call_locked (call_reference=25316, token=0x82c0f18 "ip$localhost/25316") at chan_h323.c:1154
      pvt = (struct oh323_pvt *) 0x8262688
      #2 0xb5547b6f in cleanup_connection (call_reference=25316, call_token=0x82c0f18 "ip$localhost/25316") at chan_h323.c:2300
      pvt = (struct oh323_pvt *) 0x82c0f30
      #3 0xb554aa20 in MyH323EndPoint::OnConnectionCleared () from /usr/lib/asterisk/modules/chan_h323.so
      No symbol table info available.
      #4 0xb7b5b9c1 in H323Connection::OnCleared () from /usr/local/lib/libh323_linux_x86_r.so.1.18.0
      No symbol table info available.
      ASTERISK-1 0xb7b93342 in H323EndPoint::CleanUpConnections () from /usr/local/lib/libh323_linux_x86_r.so.1.18.0
      No symbol table info available.
      ASTERISK-2 0xb7b843c4 in H323ConnectionsCleaner::Main () from /usr/local/lib/libh323_linux_x86_r.so.1.18.0
      No symbol table info available.
      ASTERISK-3 0xb7392a9f in PThread::PX_ThreadStart () from /usr/local/lib/libpt_linux_x86_r.so.1.10.0
      No symbol table info available.
      ASTERISK-4 0xb7ef5b63 in start_thread () from /lib/tls/libpthread.so.0
      No symbol table info available.
      ASTERISK-5 0xb6eda18a in clone () from /lib/tls/libc.so.6
      No symbol table info available.
      (gdb)

        Activity

        Sergey Tamkovich added a comment -

        danpwi, are you available on IRC? or email?

        danpwi added a comment -

        sure, email (reversed) moc.htuosiwp@piov

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 114120

        U branches/1.4/channels/chan_h323.c

        ------------------------------------------------------------------------
        r114120 | qwell | 2008-04-14 13:26:53 -0500 (Mon, 14 Apr 2008) | 7 lines

        The call_token on the pvt can occasionally be NULL, causing a crash.

        If it is NULL, we can skip this channel, since it can't the one we're looking for.

        (closes issue ASTERISK-9028)
        Reported by: vazir

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=114120

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 114121

        _U trunk/
        U trunk/channels/chan_h323.c

        ------------------------------------------------------------------------
        r114121 | qwell | 2008-04-14 13:29:09 -0500 (Mon, 14 Apr 2008) | 15 lines

        Merged revisions 114120 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r114120 | qwell | 2008-04-14 13:31:57 -0500 (Mon, 14 Apr 2008) | 7 lines

        The call_token on the pvt can occasionally be NULL, causing a crash.

        If it is NULL, we can skip this channel, since it can't the one we're looking for.

        (closes issue ASTERISK-9028)
        Reported by: vazir

        ........

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=114121

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 114122

        _U branches/1.6.0/
        U branches/1.6.0/channels/chan_h323.c

        ------------------------------------------------------------------------
        r114122 | qwell | 2008-04-14 13:29:29 -0500 (Mon, 14 Apr 2008) | 23 lines

        Merged revisions 114121 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/trunk

        ................
        r114121 | qwell | 2008-04-14 13:34:17 -0500 (Mon, 14 Apr 2008) | 15 lines

        Merged revisions 114120 via svnmerge from
        https://origsvn.digium.com/svn/asterisk/branches/1.4

        ........
        r114120 | qwell | 2008-04-14 13:31:57 -0500 (Mon, 14 Apr 2008) | 7 lines

        The call_token on the pvt can occasionally be NULL, causing a crash.

        If it is NULL, we can skip this channel, since it can't the one we're looking for.

        (closes issue ASTERISK-9028)
        Reported by: vazir

        ........

        ................

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=114122


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development