Asterisk
  1. Asterisk
  2. ASTERISK-9154

Loud noise heard after 2nd person joining conference bridge is announced.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Labels:
      None
    • Mantis ID:
      9430
    • Regression:
      No

      Description

      If 'Announce Callers' is checked/selected (on gui), after the 2nd caller and any additional callers are announced, a very loud squelching sound is heard. We currently have this feature unselected to avoid hearing the sound.

      We are using AsteriskNOW Beta4 w/X-Lite SIP phones.

      However, the sound is also heard when calling from a hard phone calling via an AVAYA PBX via PRI to a TE110P.

      I've attached the debug log (logger.conf = notice, warning, error, debug).

                • ADDITIONAL INFORMATION ******

      Unable provide SVN number as the command 'svn info' returns 'svn: '.' is not working copy

      1. meetme-r69809.diff
        0.7 kB
      2. meetme-r72435.diff
        0.6 kB
      3. verbosedebug.txt
        510 kB

        Activity

        Hide
        Leif Madsen added a comment -

        Have the same squelch issue (using: MeetMe("SIP/mixmiami-sbc01-09cf40a0", "9-lmentinc|doi1") as the MeetMe() arguments).

        Before the patch I get a squelch. After the meetme-r72435.diff patch I end up with no tone at all. Unfortunately this isn't working, so let me know if you need any more information or testing.

        Show
        Leif Madsen added a comment - Have the same squelch issue (using: MeetMe("SIP/mixmiami-sbc01-09cf40a0", "9-lmentinc|doi1") as the MeetMe() arguments). Before the patch I get a squelch. After the meetme-r72435.diff patch I end up with no tone at all. Unfortunately this isn't working, so let me know if you need any more information or testing.
        Hide
        Leif Madsen added a comment -

        Sergee: any luck on an alternative patch?

        Show
        Leif Madsen added a comment - Sergee: any luck on an alternative patch?
        Hide
        Sergey Tamkovich added a comment -

        blitzrage, can you explain what did you mean by "no tone at all"? i would like to chant with you, what is the best time to catch you on IRC? (in GMT please )

        Show
        Sergey Tamkovich added a comment - blitzrage, can you explain what did you mean by "no tone at all"? i would like to chant with you, what is the best time to catch you on IRC? (in GMT please )
        Hide
        Leif Madsen added a comment -

        Hey Sergee!

        By no tone at all, I mean that I don't hear any sort of sound when joining the conference (no squeal, no standard tone).

        You can catch me on IRC all day today, starting now (I'm -0400 GMT). It is currently 8:45am -0400 EDT.

        Show
        Leif Madsen added a comment - Hey Sergee! By no tone at all, I mean that I don't hear any sort of sound when joining the conference (no squeal, no standard tone). You can catch me on IRC all day today, starting now (I'm -0400 GMT). It is currently 8:45am -0400 EDT.
        Hide
        Steve Murphy added a comment -

        Many thanks to sergee for his input to this issue.

        I presented this issue to file, who whipped up the patch just posted. It goes more to the heart of the issue: the second attempt to pump audio into a file descriptor seems to have problems. He re-arranged the code slightly and re-opens the descriptor, which seems to solve the problem. The loud squelch was the sound of the normal beep-beep being played much faster than desirable. The leave tone was also so affected, but not as loudly.

        patched in 1.4 with 77191.
        patched in trunk with 77217.

        Show
        Steve Murphy added a comment - Many thanks to sergee for his input to this issue. I presented this issue to file, who whipped up the patch just posted. It goes more to the heart of the issue: the second attempt to pump audio into a file descriptor seems to have problems. He re-arranged the code slightly and re-opens the descriptor, which seems to solve the problem. The loud squelch was the sound of the normal beep-beep being played much faster than desirable. The leave tone was also so affected, but not as loudly. patched in 1.4 with 77191. patched in trunk with 77217.

          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development