Asterisk
  1. Asterisk
  2. ASTERISK-975

[patch] Manager Redirect with two parties sometimes gets second party hungup

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: Core/General
    • Labels:
      None
    • Mantis ID:
      981
    • Regression:
      No

      Description

      using the manager action below I have an application transferring a SIP and a Zap channel into a meetme room:

      Action: Redirect
      Channel: Zap/1-1
      ExtraChannel: SIP/ab123-f4d3
      Exten: 1234
      Context: default
      Priority: 1

      about 33% of the time, even on a non-loaded machine, the channel listed in ExtraChannel will just drop and not transfer to the meetme room, no matter if it is the Zap or SIP channel. It seems like the Redirect is happening for the Channel and when it gets around to transferring the ExtraChannel Asterisk is saying that the call has ended and assumes that it us hungup. Is there any way to get this working more reliably?

      1. 0000981-channel.c.comprehensive.patch
        2 kB
      2. 0000981-channel.c.may.patch
        2 kB
      3. 0000981-channel.c.patch
        2 kB
      4. 0000981-channel.c.zombiefix_delta.patch
        0.4 kB
      5. 0000981-channel.h.may.patch
        0.3 kB
      6. 0000981-manager.c.may.patch
        3 kB
      7. 0000981-pbx.c.patch
        0.5 kB
      8. 0000981-zomb_hangup.txt
        1 kB
      9. 0000981-zomb_no_hangup.txt
        1 kB

        Activity

        Mark Spencer added a comment -

        I guess more fundamentally the issue is this: You have to start both masquerades at the same time, because if the two channels are related (which they generally are) you don't want one receiving the hangup while you're masquerading the first.

        nicolasg added a comment -

        Matt: Maybe you will find useful to subscribe to asterisk-cvs if you are not alredy subscribed, so you can see what changes are being commited, related to wich bug, etc.

        Mark: Thanks for your time and effort. Today is like July 4 in my country, so I'm not at the office to test it deeply, but the latest change seems to fix the problem. I tried the dual redirect twice and it worked ok, with no deadlocks nor crash. Thanks again!

        Mark Spencer added a comment -

        Fixed in CVS

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 2206

        U trunk/channel.c

        ------------------------------------------------------------------------
        r2206 | markster | 2008-01-15 14:44:03 -0600 (Tue, 15 Jan 2008) | 2 lines

        Fix minor ordering issue (bug ASTERISK-975)

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=2206

        Digium Subversion added a comment -

        Repository: asterisk
        Revision: 2207

        U branches/v1-0_stable/channel.c

        ------------------------------------------------------------------------
        r2207 | markster | 2008-01-15 14:44:04 -0600 (Tue, 15 Jan 2008) | 2 lines

        Minor reordering for bug ASTERISK-975

        ------------------------------------------------------------------------

        http://svn.digium.com/view/asterisk?view=rev&revision=2207


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development