Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: None
    • Labels:
      None
    • Mantis ID:
      18756
    • Regression:
      No

      Description

      I'm running 1.8.2.2 on Fedora 14.

      dahdi_cfg -vvv
      DAHDI Tools Version - 2.1.0.2

      DAHDI Version: 2.4.0
      Echo Canceller(s): OSLEC
      Configuration
      ======================

      Channel map:

      Channel 01: FXO Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 01)
      Channel 02: FXO Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 02)
      Channel 04: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 04)

      3 channels to configure.

      Setting echocan for channel 1 to oslec
      Setting echocan for channel 2 to oslec
      Setting echocan for channel 4 to oslec

      dahdi_hardware
      Unrecognized garbage 'Reserved' in WCTDM/4/2
      pci:0000:01:05.0 wctdm+ e159:0001 Wildcard TDM400P REV I

      Here's a call coming in over PSTN to dahdi/4, connected to a local extension dahdi/1:

      – Executing [s@incoming-pstn-line:1] Answer("DAHDI/4-1", "") in new stack
      ..........
      – Executing [s@incoming-pstn-line:6] Dial("DAHDI/4-1", "DAHDI/g0,36") in new stack
      – Called g0
      – DAHDI/1-1 is ringing
      – DAHDI/1-1 is ringing
      – DAHDI/1-1 answered DAHDI/4-1
      – Native bridging DAHDI/4-1 and DAHDI/1-1
      – Hanging up on 'DAHDI/1-1'
      – Hungup 'DAHDI/1-1'
      == Spawn extension (incoming-pstn-line, s, 6) exited non-zero on 'DAHDI/4-1'
      – Hanging up on 'DAHDI/4-1'
      – Hungup 'DAHDI/4-1'

      I'm on dadhi/1. After 10-15 minutes, the call just drops.

                • ADDITIONAL INFORMATION ******

      Same thing on outbound:

      – Executing [s@DialOut:16] Dial("DAHDI/1-1", "DAHDI/4/xxxxxxxxxx") in new stack
      – Called 4/xxxxxxxxxxxxxx
      – DAHDI/4-1 answered DAHDI/1-1
      – Native bridging DAHDI/1-1 and DAHDI/4-1
      – Native bridging DAHDI/1-1 and DAHDI/4-1
      – Native bridging DAHDI/1-1 and DAHDI/4-1
      – Native bridging DAHDI/1-1 and DAHDI/4-1
      – Native bridging DAHDI/1-1 and DAHDI/4-1
      – Native bridging DAHDI/1-1 and DAHDI/4-1
      – Hanging up on 'DAHDI/4-1'
      – Hungup 'DAHDI/4-1'
      == Spawn extension (DialOut, s, 16) exited non-zero on 'DAHDI/1-1'

        Activity

        Sean Darcy added a comment -

        I'm trying dahdi svn to see if that helps. Can't build dahdi-linux because of pciradio, but I did build dahdi-tools from svn.

        ./xpp/dahdi_hardware -v
        pci:0000:01:05.0 wctdm+ e159:0001 Wildcard TDM400P REV I

        so the "garbage" reference no longer appears.

        Shaun Ruffell added a comment -

        After the asterisk-dev [1] discussion, is this still an issue? I'm a little uncertain from the comments.

        [1] http://lists.digium.com/pipermail/asterisk-dev/2011-February/047878.html

        Sean Darcy added a comment -

        I've installed dahdi from trunk. So far no dropped calls. But I haven't really used it much either. It's probably a good idea to close this. I'll open another if the problem returns.

        Thanks.

        Shaun Ruffell added a comment -

        Sounds good. Thanks.


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development